×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

OSPF - auto summary?

OSPF - auto summary?

OSPF - auto summary?

(OP)
Hi,

How do you set no-autosummary for OSPF?

I'm working on a Boson Netsim for the ICND2 exam.  I'm a little burnt out, but I'm hoping I can soldier on...

Anyway, I've set up 2 routers connected via PPP serial, and I've setup NAT for a few workstations connected to Router1.  I can get traffic moving fine with RIP and EIGRP, however when I set it up with OSPF, the traffic doesn't find it's way back.  Here's the Show IP Route for Router 2

Gateway of last resort is not set

C    192.168.2.0 is directly connected, Serial0
     172.20.0.0/32 is subnetted, 1 subnets
O       172.20.1.10 [110/128] via 192.168.2.1, 00:09:28, Serial0

I'm positive this is a subnetting issue, as adding a static route, or switching to RIP or EIGRP fixes the issue.

Any ideas?

RE: OSPF - auto summary?

Hmm, make sure your network statements are correct. No-auto-summary is default on OSPF/ Post a topology and configs if you need help/

CCNP

RE: OSPF - auto summary?

(OP)
Excellent, thanks so much for your help.  The link below has donwload links for both router configs, and a netmap.  Any info / critique you could offer would be great.  This was just for practicing NAT, but I got stuck on it for a minute, b/c I had OSPF as the routing protocol.  Once I changed to EIGRP, everything worked.  Quite frustrating.


https://www.yousendit.com/transfer.php?action=batch_download&batch_id=YWhQRFFjcklZY1JFQlE9PQ

RE: OSPF - auto summary?

Hmm, both of the configs are R1, no router 2 as far as i can see. Try Running area 0, ospf does some crazy shit when there is no backbone area as defined by the standard.

CCNP

RE: OSPF - auto summary?

(OP)
Sorry about that, here's the R2 config:
Version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2
ip cef
!
username R1 password jacq
!
ip subnet-zero
!
interface Serial0
 ip address 192.168.2.2 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 ppp authentication chap
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Ethernet1
 no ip address
 no ip directed-broadcast
 shutdown
!
router ospf 14
 network 192.168.2.0 0.0.0.255 area 0
!
ip classless
no ip http server
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
no scheduler allocate
end

RE: OSPF - auto summary?

You have a couple issues:

1. Your network statement on the Serial interface between R1 and R2 places the interfaces in different areas on the same link. OSPF won't form an adjacency there.

2. You have no network statement to advertise the e0 network to R2.

Here's a suggested fix for R1:

router ospf 12
 network 192.168.1.0 0.0.0.255 area 13
 network 172.20.1.0 0.0.0.255 area 13
 network 192.168.2.0 0.0.0.255 area 0

HTH

RE: OSPF - auto summary?

Ill give you a star for your efforts!

Lee

LEEroy
MCNE6,CCNP,CWNA,CCSA,Project+

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close