Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here


Microsoft Management Console has stopped working

Microsoft Management Console has stopped working

Microsoft Management Console has stopped working

Trying to get into server manager on Windows 2008 R1, every time I open it it opens for less than a second then crashes.  Debug does nothing.  Below is the event log entry:

Log Name:      Application
Source:        Windows Error Reporting
Date:          5/19/2010 10:38:20 AM
Event ID:      1001
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      sarsgrid.dccc.edu
Fault bucket 571635009, type 5
Event Name: CLR20r3
Response: None
Cab Id: 0

Problem signature:
P1: mmc.exe
P2: 6.0.6002.18005
P3: 49e01c0a
P4: Microsoft.Windows.ServerManager
P6: 49e037dd
P7: 1914
P8: 106
P9: System.UnauthorizedAccess

Attached files:

These files may be available here:

Thanks in advance

RE: Microsoft Management Console has stopped working

Additional information: Tried rebooting the server, applying updates... there are currently 18 updates available but for some reason the system will not install them. Could be related? Not sure.  

RE: Microsoft Management Console has stopped working

Are you using the default administrator login or are you using a different account that is in the adminstrator group?  They don't have the same privileges unless you modified them.

RE: Microsoft Management Console has stopped working

Thanks for the reply.  I tried logging on with the Administrator account but the same issue is still there.  MMC crashes right away and I cannot install updates.  Here's the error I get when trying to install updates:

Code 80070005 Windows Update encountered an unknown error.

Also the other two Windows 2008 R1 servers that I administer both work fine with the alternate administrator account.  I'm going to follow the link on the error listed above and see if that helps, but any other ideas?  Thanks again!

RE: Microsoft Management Console has stopped working

Woohoo!  Found the solution when tracking down that error!

The DCOM configuration was not correct for some reason.  Don't know how it got changed, maybe it's something the developer did when they installed the application.  Anyway, this is the procedure I ran to fix it:

1. Click Start, click Run, type Dcomcnfg, and then click OK.
2. Expand Component Services, and then expand Computers.
3. Right-click My Computer, and then click Properties.
4. Click the COM Security tab.
5. Under Access Permissions, click Edit Default.
6. Verify that the following accounts are listed:

Comparing the broken server to one that worked, the broken server had Everyone listed with local and remote access.  The one that works did not have Everyone listed.  I removed it in the broken server and hit apply.  Everything else looked OK.

Step 2: Verify DCOM default properties
1. Click the Default Properties tab.
2. Verify that the following configuration:
• The Enable Distributed COM on this computer check box is selected.
• In the Default Authentication level box, Connect is selected.
• In the Default Impersonation level box, Identify is selected.

3. Make any required changes, and then click OK.
4. Restart the computer.

In this case, the broken server had Default Impersonation set to Anonymous.  I changed it to Identify and it gave me an error when I clicked OK saying I didn't have the permissions to do that.  However, the change took, I didn't have to reboot at all, and now MMC opens fine and Windows Update works fine too.  This problem is RESOLVED!  Thanks again! upside down

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close