VLAN's not working between Intel NIC and Cisco switch
VLAN's not working between Intel NIC and Cisco switch
(OP)
I have an IBM Lenovo ThinkCentre mini-tower with an Intel 82566DM-2 gigabit NIC. I'm trying to establish VLAN's between it and a Cisco 3750 switch. I'm able to configure VLAN's on the NIC and have the switch configured for trunking, but am unable to ping default gateways or other systems on the network.
Any thoughts on what I might be missing in my configuration?
Any thoughts on what I might be missing in my configuration?
RE: VLAN's not working between Intel NIC and Cisco switch
Take Care
Matt
I have always wished that my computer would be as easy to use as my telephone.
My wish has come true. I no longer know how to use my telephone.
RE: VLAN's not working between Intel NIC and Cisco switch
RE: VLAN's not working between Intel NIC and Cisco switch
/
tim@tim-laptop ~ $ sudo apt-get install windows
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package windows...Thank Goodness!
RE: VLAN's not working between Intel NIC and Cisco switch
Switch Config for the port:
switchport trunk encapsulation dot1q
switchport trunk native vlan 9
switchport mode trunk
switch port nonegotiate
RE: VLAN's not working between Intel NIC and Cisco switch
/
tim@tim-laptop ~ $ sudo apt-get install windows
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package windows...Thank Goodness!
RE: VLAN's not working between Intel NIC and Cisco switch
RE: VLAN's not working between Intel NIC and Cisco switch
int fa1/0/1
ip add 10.1.1.1 255.255.255.252
no shut
descr to-IBM
!
int fa1/0/2
switchport
switchport mode access
switchport access vlan 10
!
int vlan 10
ip add 192.168.1.129 255.255.255.128
no shut
!
that's an example of how it would be done. Then make a default route
ip route 0.0.0.0 0.0.0.0 10.1.1.1
and make the IBM 10.1.1.1
All the vlans would use their respective SVIs in the switch as their gateways, and the switch would forward all unknown traffic to the IBM, which would forward its traffic out its directly connected interface.
/
tim@tim-laptop ~ $ sudo apt-get install windows
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package windows...Thank Goodness!
RE: VLAN's not working between Intel NIC and Cisco switch
RE: VLAN's not working between Intel NIC and Cisco switch
NIC 1 - connection to "real world" routed network
IP: 205.54.3.22; DGW: 205.54.3.1
NIC 2 - connection to internal private networks
Sub-interface 1 IP: 192.168.10.130
Sub-interface 2 IP: 192.168.105.130
Sub-interface 3 IP: 192.168.45.130
Sub-interface 4 IP: 10.15.10.130
If the machine is looking for a system on any of the 192.168. or 10.15.10 networks, it knows about those and will send the data to the appropriate sub-interface. If it's looking for a system not on those networks, then it is sent out NIC 1 to the DGW address 205.54.3.1.
The problem I've having is that I can't get the Cisco switch and NIC 2 to communicate properly using VLAN tagging and am wondering what I might be missing in the setup.
Thanks for the help.
RE: VLAN's not working between Intel NIC and Cisco switch
By the way, you need to do the switchport command before you do switchport mode trunk, etc...
switch(config-if)#switchport
switch(config-if)#switchport mode trunk
switch(config-if)#switchport trunk encaps dot1q
switch(config-if)#switchport trunk allowed vlans 9,18,27,36,45
and make one of the vlans the layer 3 routing vlan to the server.
Is that all you did with the NIC, just set up subinterfaces?
/
tim@tim-laptop ~ $ sudo apt-get install windows
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package windows...Thank Goodness!