×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Disk Failure Netware 6.5

Disk Failure Netware 6.5

Disk Failure Netware 6.5

(OP)
Hi

I have anetware 6.5 SP7 server on an IBM x206 box with 2gb RAM

I have 4 maxtor 300gb ide drives in the machine.

the dos partition is on disk 0.

my data pool keeps deactivating with a read error.

I can boot fine and everything loads, but I cant stop it trying to remirror the partition and then it fails on the same file everytime within about 30 seconds after loading the data partition.

Disk 0 and 1 are mirrored and disk 2 and 3 are mirrored at the softare level within netware.

If I remove disk 0 i cant boot due to invalid partition table.

If I put a new drive with just a dos partition on and boot then the data pool does not exist.

As the disks are mirrored and it can find sys with only one disk why cant it find data?  what is the point of mirroring as it appears that one disk ahs failed and the mirror is not working?

Is there anyway to get it working again?

At the moment I am trying to ghost the damamged disk to a new disk, which has about 4 hours to run?

The only data on the server is Groupwise and it would really help to get the data off.  As usual the back up is a couple of months out of date.

Thanks

Kevin

RE: Disk Failure Netware 6.5

You have to isolate the problem disk.  If you pull disks 2 & 3 and then try to boot to just the operating system and are successful, then you know that the problem is with one of those two disks.

Then, put them back in one at a time and see when the problem returns.

You should be able to boot to disk 1 (with Disk 0 out) BUT ONLY IF you also duplicated the DOS partition and the files within that DOS partition.  If you didn't, then you only have the SYS volume (perhaps) on those disks and that's why it won't boot.

RE: Disk Failure Netware 6.5

By the way - this is why HARDWARE RAID (mirroring) is far superior to software.  It makes every bit of the hard drives redundant without you having to resort to xcopying and duplicating a DOS partition.

I used to do this periodically when I had softare mirroring - boot to dos and do an xcopy c:\*.* d:\

You may be in deep trouble here.   I would use this an opportunity to try to get a system that has hardware RAID, if you don't get scapegoated for this incident.

RE: Disk Failure Netware 6.5

(OP)
Hi

Thansk for the comments.

I know the faulty disk is disk 0.

I have discovered the dos partition missing so i dropped it on a 20gb drive and booted with this and disk 0 mising. the server started and there was a messge which disapperead but was something like it could not find the data pool and deleted it!

I put back the original disk 0 and removed disk 1 but the same problem the pool is now missing.

I have cloned the disk 0 onto another identical disk but this did the same as well.

I have found some software called nucleus kernel nss recovery, which claims to recover volumes.

I am currently running thsi but it is goign to take few hours to search the whole disk to find the pools.  If thsi worsk then i can copy the data of the disk, reboot and recreate the data volume, then copy the data back.

As I have a 7 tray LTO drive I will also make sure that this is working again.

Any other ideas on recovering pools would be useful in case this fails.

Thanks


 

RE: Disk Failure Netware 6.5

Just recreate the pool and restore the data from backup.  That's the much easier way to do it.

You do have backup - I hope.

RE: Disk Failure Netware 6.5

(OP)
If I had a backup I would not be asking here!  The back up two weeks old and I need some emails from last week.  Particualry one I sent on Friday with some received before as it is part of a court case.  I was going to print it all on Saturday!

Anyway I have now tried the followng software whicha ll purport to recover lost pools from deletion even over formatting yet none of them can find any trace of the DATA pool.

Kernel Nucleus NSS Recovery - www.nucleustechnologies.com
Quick Recover NSS – www.recoveryourdata.com
Recover Data for NSS - www.novelldiskrecovery.com

However, the software from www.stellarinfo.com did find a data volume but onyl with one directory.

The current problem is that the search by all the software takes around 4 or 5 hours to complete per disk so it is a very long process to find out which one will work.

Can anyone recommedn any data recovery houses in the UK which are reliable for this sort of thing?
 

RE: Disk Failure Netware 6.5

I'm sorry for your problems, but I can't believe that your backup is that old.   I'm hoping that was not under your jurisdiction.

Maybe it's best to just restore from backup and get going on a new hard drive and then worry about restoring from the original hard drives later.  I mean, it's going to take a few days to get the data restored (if it can be recovered) from a professional restoration service.

I can't recommend one "over there".   Our company uses Gillware (gillware.com) in the U.S.  You COULD send your hard drive to them though for the recovery..

RE: Disk Failure Netware 6.5

(OP)
Yep doing that using backup, but still inrigued as to why the pool vanished.

I have now tried the latest verison of Portlock storage manager which sees the pool fine!!! it can see the pool segments on the disks etc.

However, as netware cant see the pool - somehow it is deleted, yet is still in NDS tree.  Portlock can nto do much with it.  

Portlock also hasan error "invlaid 3rd superblock" when running any of its functios that prevents it from imaging or anything else.

Well progress is slwo but improving - at least I found the pool.  Now to access it!

I have had a quote from OnTrack for data recovery but is between £2,000 to £4,000 and a non returnable £200 diagnostic fee to give the final price even if they cant recover anything.

Anyway I am now wiating for Portlocks Tech Support to see what they come back with.

Thansk for all your help - I will keep you informed of results.

In the meatime all suggestions are always welcome.

RE: Disk Failure Netware 6.5

Here's the million dollar (pound) question.  Are you going to lose your job if it costs your company that 2000-4000 pounds????

RE: Disk Failure Netware 6.5

Hi, I am new to this forum and we have a similar problem to the one above.  We have isolated the folder that contain the corrupted file(s), but we cannot access the folder to delete it in any manner.  Including the different utilities in Netware (cpqfm.nlm, cc.nlm, vrepair, nss.nlm, etc.)

We have restricted access to the folder so users cannot try to open this folder, but we know that if it is even searched on, it will cause the pool to deactivate.

We are able to restart the server with no problems, but we are at a loss as to how to safely remove this folder.  Any help is greatly appreciated.

Dan Kirby

RE: Disk Failure Netware 6.5

Please don't piggyback on an existing thread.  Start your own with an appropriate title in the same area.

Advice:  Give more information on disk structure (RAID??  Controller brand/model??? Logical drives, Disk types, number of disks).  Kill us with information.  You gave nothing to start with.

If RAID, have you run a consistency check?

If not RAID, have you run disk diagnostics on the drives??

Post your own thread and continue from there.

RE: Disk Failure Netware 6.5

Portlock can recover it. They are good.  

Marvin Huffaker, MCNE
Marvin Huffaker Consulting, Inc.
A Novell Platinum Partner
http://www.redjuju.com

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close