×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

SDL library version error

SDL library version error

SDL library version error

(OP)
hi, i've just downloaded a test game to try compiling it with the gcc compiler in Solaris, the problem was that ./configure command return this error




*** Could not run SDL test program, checking why...
*** The test program compiled, but did not run. This usually means
*** that the run-time linker is not finding SDL or finding the wrong
*** version of SDL. If it is not finding SDL, you'll need to set your
*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point
*** to the installed location  Also, make sure you have run ldconfig if that
*** is required on your system
***
*** If you have an old version installed, it is best to remove it, although
*** you may also be able to get things to work by modifying LD_LIBRARY_PATH
configure: error: *** SDL version 1.1.6 or above not found!




if needed I'll post even the previous output, anyway I've just installed the 1.2.x SDL lybrary and used the crle -l command, and now in the crle output there is even the /usr/local/lib directory. What should I do? Is there a previous version of SDL library installed on Solaris by defautl? how can I control the version of SDL library on my OS ? I can't manage to solve the problem.

p.s. thanks domburns62  for the grub help
 

RE: SDL library version error

As the message says, if you set your LD_LIBRARY_PATH to the location of the SDL library you have installed, I'm guessing /usr/local/lib, then it should be able to find it:

CODE

export LD_LIBRARY_PATH=/usr/local/lib

Annihilannic.

RE: SDL library version error

(OP)
i tried this but it returns this error

LD_LIBRARY_PATH=/usr/local/lib: is not an identifier


the english traduction should be like that one. , anyway I've even tried to do

LD_LIBRARY_PATH=/usr/local/lib
export LD_LIBRARY_PATH

and this worked , but the configuration error still remains, are the SDL library a package ? can I verify their version somewhere? I don't understand why their are not being recognized from the OS.  

RE: SDL library version error

www.sunfreeware.com often supply pre-built packages of freeware like SDL, but for some reason SDL isn't listed on their main page.

They do have an x86 version here:

http://www.sunfreeware.com/ftp/pub/freeware/i386/10/sdl-1.2.13-sol10-x86-local.gz

I couldn't see a SPARC equivalent.  What platform are you on?

I guess there could be problems with that package though if they haven't listed it on their main page for some reason.

What package is the existing SDL library on your system part of?  Where did you get it from?

Annihilannic.

RE: SDL library version error

(OP)
I've installed the 2.13 version of SDL libraries, this time the error messagge changed a little bit


*** Could not run SDL test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means SDL was incorrectly installed
*** or that you have moved SDL since it was installed. In the latter case, you
*** may want to edit the sdl-config script: /usr/local/bin/sdl-config
configure: error: *** SDL version 1.1.6 or above not found!


If I execute /usr/local/bin/sdl-config --version , it returns 1.2.13, this should means that the system recognize the right version, isn't it? why doesn't the program do the same ? I've installed the SDL package without modifing no-one of the standard parameters , so I only have to add the /usr/local/lib path to the system paths with the crle command, right?

RE: SDL library version error

What game are you trying to compile?  I'll try installing that library and compiling it myself.

Annihilannic.

RE: SDL library version error

(OP)
i'm trying with abuse, it's the first game I've found , but this or another one is the same for me, I just want the SDL libraries to work correctly, this game in particular is not so important

RE: SDL library version error

Link to source code?

Annihilannic.

RE: SDL library version error

(OP)
finally i found the 1.2.9 version of the sdl libraries and that error doen't appear anymore , but I 've read that it was best to use the gnu make, so I've gone to the sunfreeware site downloaded it. Then I removed SUNWgmake and installed the  gnumake , now the compile process ends without errors , but the make one end with this


 -L/usr/openwin/lib -lX11 -lXext -lposix4 - L/usr/lib -lGL -lpthread   -Wl,-R -Wl,/usr/local/lib -Wl,-R -Wl,/usr/local/lib
ld: warning: file /usr/local/lib/libstdc++.so: attempted multiple inclusion of f ile
Undefined                       first referenced
 symbol                             in file
SDL_SaveBMP_RW                      sdlport/libsdlport.a(event.o)
SDL_LoadBMP_RW                      sdlport/libsdlport.a(video.o)
SDL_RWFromFile                      sdlport/libsdlport.a(video.o)
SDL_MixAudio                        sdlport/libsdlport.a(sound.o)
ld: fatal: Symbol referencing errors. No output written to abuse
collect2: ld returned 1 exit status
make[3]: *** [abuse] Error 1
make[3]: Leaving directory `/Desktop/softSource/abuse-0.7.1/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/Desktop/softSource/abuse-0.7.1/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/Desktop/softSource/abuse-0.7.1'
make: *** [all] Error 2

i googled and find that ld is the linker application, maybe I've to install the GNU version, to make it works , but I can't find it for download.  

RE: SDL library version error

You shouldn't need GNU make.  Even if you do find you need it, you shouldn't need to uninstall the Solaris make to use it.

Similarly you shouldn't need the GNU linker; those are genuine linker errors that would be reported by any linker.

Well, I tried with that sdl-1.2.13-sol10-x86-local package I pointed you to and had the same error as you ("SDL version 1.1.6 or above not found!").  It turned out that the test programme was not compiling due to a missing libiconv2 (which the configure script should probably be checking for separately).  Anyway, I downloaded and installed that from SunFreeware.com, tried again, and then had similar linker errors to you, but for different functions (SDL_HasMMX).  It's a bit baffling that SDL is unable to find functions which should apparently be defined in its own library; I'm guessing it hasn't been tested much on other platforms, and this could explain why it isn't available in the usual place on SunFreeware.com.

Where did you find SDL 1.2.9?  Blastwave.org?

Annihilannic.

RE: SDL library version error

(OP)
first off thanks for the help giving.

After I searched so much,I arrived to this page http://www.libsdl.org/release/
here there is a list of SDL release.

I searched the SUNWgmake on the solaris installation dvd, and found a folder with a lots of SUNW....  subfolders, are that the solaris original packages? for reinstalling the SUNWgmake on my system I just have to copy the SUNWgmake folder back to the folder that contains all the others SUNW... package on my hard disk?

RE: SDL library version error

No, you need to use pkgadd -d /path/to/SUNWmake/on/DVD to reinstall the package.  

I hope you removed it using pkgrm and not just by removing the files?  In any case, reinstalling should hopefully tidy things up.

Annihilannic.

RE: SDL library version error

(OP)
i've  managed to do it , thanks for the help!

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close