×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

MML failed

MML failed

MML failed

(OP)
I am getting the following error message when trying to retrieve a call/interaction that has been archieved.  "Connection to MML failed, please check the connection and retry".
System is running NICE Perform Release 3.1 V.9.10.5.382

RE: MML failed

Does this occur for all archived calls you try to replay?

Do you record screen?

Do you archive screen?

Do the calls you're experiencing this with include screen?

RE: MML failed

(OP)
No Screen recording is done, it only happens on archived calls to replay.  I find it strange that I am getting that error because we are not doing screen capture.

RE: MML failed

I've seen this before but cannot remember the cause.  Have you ever been able to replay from storage center?  I'm thinking this might be a firewall or permissions issue.  Ignore the message about MML I think it's a red herring.  Are there any other error messages.  From your workstation you are replaying from are you able to open the share location where the archived calls are kept?  You require at least read permissions on this location.

RE: MML failed

(OP)
I verified the permissions between the workstations and the Storage center (NICE Perform) server, there are no firewalls between the desktops and servers.  The only firewall that exist is from the Storage Center (NICE Perform) to the EMC Centara and thay connectivity has also been verified.  I downloaded a utility from EMC and put it on the server which verifies connectivity to the Centara.  I also did a basic telent port 3218 to Centara and that verified communicatoins.  I do notice that on some retrivals I get a "TSM fail" on the first archive request from NICE, I'll request the media again and if pulls down successfully but when I select play I get the MML error.  I then check the retrieve folder on the NICE server and the file was actually retrieved.  So I am not sure why I do get the MML error if the retrieve actually works.  NICE has asked me to do basic 101 troubleshooting "Ping, Tracert, DNS Host resolution of the server etc."  so just waiting on them to ask the next set of scripted questions.

RE: MML failed

if there is no screen recording on site and you still have mml  failed errors.
 you may check  the QA rules .İf there is any agent grp   rules including screen and voice.? uncheck the screen..
check the call details on recording tab. is there any  initiator  type  QM? or only  total.

 

RE: MML failed

Not sure if you have tried this but from the workstation you are replaying from physically navigate to the retrieve directory.  You need to have read permissions to this directory.  

P.S. Would have been advantageous to know you had EMC integration as this is quite specific at start as may have changed response (in this case it wouldn't but just for future reference) smile

RE: MML failed

What version of perform is this? 3.1, R3/SP3 or SP4, R2???

RE: MML failed

(OP)
To: RoamingKiwi:  I did navigate to the retrieve folder but ran into some issues with playback, some of the calls did not playback correctly, the player came up with the call but only loaded half tha call on the player and then just hung.  Same thing from another workstation.



To KingNothing72:  
We are running NICE Perform Release 3.1 - Applications Suite: Enterprise Version: 9.10.5.382.  I beleive NICE stop using service packs in R3.1, we did however do the Update Pack 17 (patch release)
  

RE: MML failed

Ok, sorry I was under the impression no calls were playing back.  

Try copying the physical nmf file to your pc and see if it plays back fine using NICE Media Player.  Sounds like a buffering issue.  Do you have a playback server or stream server configured?   

RE: MML failed

(OP)
Hi Kamran,

I am not clear what you mean by updating Host file?   We have 4 Perform 3.1 servers, 4 VoIP loggers and 4 NMS Servers.  Two of the Perform servers are configured with Storage Center (primary & secondary).  

RE: MML failed

Dear sorry for late response, just you need to follow this path, C:\windows\system32\drivers\etc\ and open host file and put all servers host names and IP Addresses.

Thank you.

RE: MML failed

(OP)
It's funny, about the host file, that's what NICE Tier 3 support suggested doing.  That did solve our issue but it made things better.  We are now not seeing any TSM Failures on archived media from EMC Centera.  The media gets retrieved successfully.  Now after updating the host file, re-installing Storage Center, re-installing the stream server manipulating the locate order etc.  there is still an issue playing back the interactions.  Once a query has been completed, the interaction shows in Business analyzer, however we are unable to play it back.  The following error occurs "Failed to retrieve playback information. Server might be down", this only happens for calls that have been archived 6 months ago or earlier.  NICE Support explained that they found more that one interactions with the same segment ID and now it has to get escalated to Tier 4 in NICE.  Thanks for the response.

RE: MML failed

what solution get from T4 about MML failed problem?

Tx

RE: MML failed

(OP)
tnice:
The end result was NICE wrote a script to correct the issues with the SQL database.  After that was implemented we were able to retrieve and playback archived media.  Now we are working on a new set of issues.. it never ends...

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close