×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

no local mail

no local mail

no local mail

(OP)
I'm not getting local mail

RE: no local mail

Are you set up for local mail?  Usually sendmail is set up to use mail or procmail as your local mailer and puts it into a file such as /var/spool/mail/username.  If you want to be able to use a client to get it, you will need a pop3 server such as qpopper or you could use fetchmail.  Both will poll the server and deliver the mail to your clients mailbox.  Sorry I couldn't be of more help, but I don't know what you are running and how you set it up.

RE: no local mail

(OP)
I have sendmail on the server and I should be able to send a message to myself with or without it running.  I just want to email a local user on the standalone server.  The issue is any user including root.  mail says it's defered but goes nowhere...

#####################
# mailx -v root
Subject: hi
.       
EOT
# root... Connecting to local...
root... Deferred
##################################

RE: no local mail

You're right.  If you are just using local mail, then sendmail doesn't even come into the picture so none of it's files should matter.  I assumed that since this post was in the sendmail forum, you couldn't get sendmail to deliver your incoming mail.  Shame on me.  The only file I know of that mail uses is /etc/mail.rc.   On some systems it may be .mailrc but that file wouldn't cause your problem so I'm thinking maybe your system is having a problem indentifying itself.  You might check your network settings.  

RE: no local mail

(OP)
Yes my issue was Sendmail not working but  when I took sendmail out of the mix I should be able to send anything via mailx.  I didn;t want to double post but  the issue is all the same.  If I can figure out why mail is defered status then I can get sendmail working again (see where I'm going with this...)

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close