×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Restoring a Norton Version 1E floppy backup

Restoring a Norton Version 1E floppy backup

Restoring a Norton Version 1E floppy backup

(OP)
thread613-18860: Norton Backup for Win3.X

I have copies of three backup floppies August 9 1993 (according to the filename) created by Norton Version 1E (according to the first few bytes of the files). I'm pretty sure the three files constitute the entire backup set, though I can't be certain.

Based on the thread I'm referencing above, I got DOS 6.22 running in VirtualBox, and started playing around with MSBACKUP. I'm not sure if I'm supposed to have a separate catalog file or not (I don't have anything with a .FUL extension). In the Restore screen, I go "Catalog..." and have the option of Retrieving or Rebuilding. Retrieving asks for the last floppy. I mount the image I made containing the third file, hit OK, and two blue message boxes flash on the screen and then I get a "Cannot retrieve catalog" error. If I try the other floppy images I get prompted that it's not the last in the set, so this is what makes me pretty certain I have all the files in the set.

I managed to pause the virtual machine on the second blue message box and it says "Now retrieving catalog ... from disk #3 in drive A.". So I wonder if my file is corrupt somehow. These were copied from floppies a long time ago, though I didn't get any read errors then (that I recall, anyway).

The other option is to rebuild the catalog. When I select that, I get to the "DOS Rebuild Catalog 6.0" screen, and I'm prompted for the first disk. I put it in, hit rebuild, and in the diskette progress on the left the "Rebuild Time" stops at 0:01 (1 second) while the "Rebuild Information" time on the right keeps ticking. In other words, it jams (I've left it running for about 15 minutes).

I honestly don't remember if I made the backup from Windows 3.1/For Workgroups 3.11/DOS. According to this page (http://www.fpns.net/willy/msbackup.htm) the compression used changed late in the game---but I figured I'd get a less cryptic error, and something other than "freezing" when trying to rebuild the catalog.

Mind you I'm running this virtual machine on a Windows 7 x64 host... my, how times change. I have no idea if this has any effect; it's my first DOS virtual machine so I don't know if there are any implications.

Anyone have any ideas?


 

RE: Restoring a Norton Version 1E floppy backup

(OP)
I worked extensively with Willy's source code from fpns.net. Got it to compile in Visual Studio 2005, and read the contents of the backup files. Unfortunately, the decompression algorithm is failing. In the process, I learned that it's likely the backups were created with DOS 6.2.

A brief history of DOS:

1. DOS 6.2 is released.
2. Microsoft gets sued for patent infringement on the very compression algorithm I'm talking about. The courts force them to stop selling 6.2. Microsoft releases 6.21 with no compression.
3. Microsoft eventually works around the patent somehow and releases 6.22.

Apparently the compression used by backup is the same that could be turned on for a FAT partition.

RE: Restoring a Norton Version 1E floppy backup

IIRC MS had some Stak code carried over by an employee who moved across. MS rewrote the problem stuff for 6.22 but later bought Stak.

Wouldn't Norton Backup have a compression of their own? I avoided compression, considering it a potential bomb, so I don't know whether they did, or not. I was also avoiding Norton in that time frame.

 

Ed Fair
Give the wrong symptoms, get the wrong solutions.

RE: Restoring a Norton Version 1E floppy backup

(OP)
Ed,

The MS Backup in DOS/Early Windows was actually bought from Norton. The About screens verify it. :)

RE: Restoring a Norton Version 1E floppy backup

(OP)
SUCCESS!

I had both DOS 6.0 and DOS 6.22 here. 6.22 wouldn't work. But the MSBACKUP from 6.0 worked.

Hooray!

Heh... then I had to download PKZIP 2.5, put it on a virtual floppy into the virtual machine to compress them into virtual floppies, and then for I had to download Winzip for my host to decompress the "old" DOS archives.

But now it's all here. Thank goodness PKWare doesn't forget their roots.

RE: Restoring a Norton Version 1E floppy backup

Good info pelesl...I didn't know that.

Skip

  

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close