×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Remote Desktop over VPN Problem, Request Help

Remote Desktop over VPN Problem, Request Help

Remote Desktop over VPN Problem, Request Help

(OP)
I am having the following problem when connecting to a Windows 2003 server on remote desktop over VPN. Here is the whole issue in outline format and what I've done to try and fix it. My ISP says everything is fine, and my IT department says everything is fine. Any other ideas?

1. The Windows VPN connects just fine, computer registers on company network.
2. While connected I can continuously ping the server using the –t option. It drops a packet here and there but then picks right back up. All replies are within the 130ms range. I've let it go for 10-15 minutes successfully.
3. Once I log onto the server via remote desktop the problem begins. Usually I can logon, and stay connected for anywhere from 15 seconds to a minute. As soon as I start to do something (open an application, check my email etc.) the remote desktop disconnects. It says it's trying to reconnect but never does.
4. Once the RD disconnects I can no longer log back into the server or even ping it. All requests time out.
5. The VPN appears that it's still connected but I cannot access anything. If I want to try logging back in I have to disconnect and reconnect VPN.
6. Back to step one and the whole cycle begins again. This happens on both my XP desktop wired to my router, and on Win. 7 laptop connected over WiFi.

What I've done to try fixing this.
1. Adjusted MTU on my router and computer registry for VPN and PPP (1200 showed no packet fragmentation on ping testing, but I experienced the same issue).
2. Opened all firewall ports on the PC's for remote desktop, VPN, PPP, everything I could find. Even tried turning my firewall off.
3. Enabled port forwarding on my router for the same services listed above.
4. Deleted VPN connection and created a new one.
5. Unchecked ipv6 as an option on Windows 7 VPN configuration.
6. Tried changing subnet mask for my local/home network as I've heard that could be an issue.

My setup
-Verizon DSL
-Linksys WRT54GS router.
-Windows 7 Laptop over wireless & Windows XP desktop wired to router.
-Remote server is located in the UK, I am in the US but I've never had these issues before. I used to connect via RSA but now just normal VPN.
-Local network IP 10.10.1.x mask 255.255.255.0 using DHCP from Linksys router.
-External Verizon IP 71.113.152.x mask 255.255.255.0
-PPP Adapter IP 10.8.1.x mask 255.255.255.255
-Remote network 10.11.23.x; I don't know the mask on this because I cannot stay on the RD long enough to perform an ipconfig.

Is there something I'm missing, or anything else I can try?

Thanks for any suggestions

RE: Remote Desktop over VPN Problem, Request Help

It does sound as if your VPN is dropping which would drop your RDP.  What are you using for a VPN client and is this a Terminal Server your connecting to?

RE: Remote Desktop over VPN Problem, Request Help

(OP)
Hi,

I am using the standard Windows VPN client, no 3rd party VPN software.  It is a terminal server I am connecting to for accessing applications.

RE: Remote Desktop over VPN Problem, Request Help

If you do not need the VPN try accessing the server via the public IP, IE: 64.10.156.109.  If it isn't available try to see if they will port forward to allow.  Also see if there is a third party software they would allow you to us.  

My experience with Windows VPN client is very good like dropping the connections.   

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close