×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

usermod command saying insufficient space

usermod command saying insufficient space

usermod command saying insufficient space

(OP)
when I try to do a usermod -d /usr/tester/<userid> -m <userid> I recieve error saying that UX: usermod: ERROR: There is not sufficient space to move.

I can do a simple usermod -d /usr/tester/<userid> <userid> and it works fine. Just having a problem when doing the -m to copy the directory now


The users home directory currently resides on an NFS mount and I am trying to move it to another NFS mounted share.  

RE: usermod command saying insufficient space

Make sure you have write permissions on the new share.

RE: usermod command saying insufficient space

(OP)
I do have write permissions set on it. I am able to manually copy the files or use rsync to copy from dir to dir. It seems that the only thing I am able not to do is the usermod with the -m option.  

RE: usermod command saying insufficient space

have you tried moving it manually, then update the /etc/passwd?

RE: usermod command saying insufficient space

I would try running the usermod command under truss -o /tmp/usermod.truss -aef usermod ... and then examine the output file to try and determine which system calls were returning incorrect information about free space.

Have you tried asking Sun?

Annihilannic.

RE: usermod command saying insufficient space

(OP)
Annihilannic
-------------
I'm not familiar with truss; but will give it a try and see what I can find/see in the output as a lead.

Haven't tried asking sun as of yet. Will get the output and involve them as I am sure the output will be helpful for them to diagnose.


ToMaC82
--------
I could copy the contents manually with rsync and then execute a usermod -d /usr/tester/<userid> <userid>. But I would really like to get the -m to work as it is intended

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close