×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Mincom Desktop Access Error

Mincom Desktop Access Error

Mincom Desktop Access Error

(OP)
Hi Everyone,

We are upgrading our Ellipse environment to version 6.3.2 on an HP-UX 11.23 platform running Oracle 10g client.  Our database server is RHEL 4 running an Oracle 10g dB.

The database is up and running and we have everything installed on the Ellipse application server (in our environment that's OS/Server Express/CICS/Oracle client/Ellipse and Ellipse components). At present we have one region set up using the naming convention of ellxxx(in this instance, elluat).

We can connect to the dB using an in house test script which simply test perl module functionality in unison with testing dB connectivity when given 3 dummy parameters....

elluat@eappsvr1 oracle_testscript.pl 1 1 1
User: ellipse  pw: ellipse
Connect instance: dbi:Oracle:elluat
Connected to database : dbi:Oracle:elluat
elluat@eappsvr1

It connected to the dB fine.  We can also connect as the mincomcm user, using the sqlplus command and entering the ellipse userid and ellipse password.....

Select an instance [2 - elluat]: 2
Subscribing to ellipse version /opt/mincom/ellipse/v6320
mincomcm@eappsvr1 sqlplus

SQL*Plus: Release 10.2.0.1.0 - Production on Thu Sep 10 16:32:54 2009

Copyright (c) 1982, 2005, Oracle.  All rights reserved.

Enter user-name: ellipse
Enter password:

Connected to:
Oracle Database 10g Enterprise Edition Release 10.2.0.4.0 - 64bit Production With the Partitioning, OLAP, Data Mining and Real Application Testing options

The problem we are facing is that we cannot connect when trying to access Ellipse from the front-end Mincom Desktop application.  Once we put in the uid and password, we receive the message "Ellipse Login - Logging into Ellipse" popup window, then "connecting to Ellipse", then it crashes with the following error message: (sorry my connection kept breaking the upload)

merm.u.9999,merm.e.9999,merme.9999......ABORT PR: MSSCDP VERS: 0048 REV: 1.2 PROG: MSK000 ....LAST SQL ERROR WAS: -3114 ORA-03114: NOT CONNECT TO ORACLE CANNOT DISPLAY STANDARD ERROR TEXT AS PROBLEM EXISTS ON THE TABLE FILE


This message populates the MERM.out.......

*** ELLIPSE ERROR LOG 11/09/09 11:39:59 ***                                     
PROGRAM = MSK000             EIBNAME =                                         |
WX-PROGRAM-ID = MSK000       WX-USER-ID =           |                          |
WX-DISTRICT =                WX-POSITION-ID =           |                      |
WX-PREV-PROGRAM-1 =          WX-PREV-PROGRAM-2 =         |                     |
  2020  OTHER                          S/R Call  MSSCDP                         
   346  OTHER                 MSQL     MSQL-346                                 
   346  OTHER                          S/R Call  MSSERM                         
LAST SQL ERROR WAS: -3114 SQL WARNING FLAGS:<********> SQL MESSAGE:             
ORA-03114: not connected to ORACLE                                              
CANNOT DISPLAY STANDARD ERROR TEXT                                              
AS PROBLEM EXISTS ON THE TABLE FILE                                             
                                                                                
The Error Description is : $UNDEFINED$                                          
EIBFN    IS x1A04 EIBRCODE IS x303030362020                                     
EIBRSRCE IS                                                             
            
****    MSF010 SYSTEM FILE NOT PRESENT     ****     


This message populates the CICS console log...

ERZ016050W/0234 09/11/09 11:42:05.755864000 elluat    7877/0001      : Logical unit of work for transaction 'CPMI' has been backed out; Distributed Transaction Service (TRAN) reason 'ENC-tra-1025: A client (not the transaction service) aborted'

This is another re-occuring message in the CICS console log which looks to be abnormal....
ERZ080095W/0801 09/11/09 12:49:40.680887000 elluat    7894/0001      : XA_OPEN for Application Server '105' with 'Oracle Single Phase' with xa_open string 'Oracle_XA+Acc=P/ellipse/######+SesTm=35+LogDir=/var/cics_regions/elluat/xa/xa+DbgFl=1' returned XAER_RMERR '-3'


Has anybody run into this issue previously that can point any suggestions or tips my way?  I'm thinking it may be a CICS related issue but I'm not savvy enough with Ellipse or CICS to determine this or the source of the problem.

Thanks for any assistance.



 

cag

RE: Mincom Desktop Access Error

Hi Cag,

Please check that your ECP has compiled properly. I think this
beast creates the single phase commit switch. (oracle1pc.mk)

Regards

Kes

RE: Mincom Desktop Access Error

(OP)
Kes,

Thanks much for your response and assistance.  You were correct.  The problem was with CICS!  Still in learning mode so hopefully I'm stating all this correctly.

What seems to have caused the problem was the inability of the EAC to update a region after we performed a 'Configure Definition' within the ellipse instance.  Therefore none of our programs were being written into CICS (Configure --> CICS Resources --> KA-PLUNK....).

We made the following changes......

1) added the 'root' user to the 'cicsterm' group
2) changed the group ownership from 'cics' to 'users' for the following files
/var/cics_regions/elluat/console.nam
/var/cics_regions/elluat/elluat.env
/var/cics_regions/elluat/symrecs.nam
3)Had DBA unlock all locked application accounts in the ellipse database
4)Performed a eacstop/eacstart

At this point the <elluat> --> right click --> Maintain --> Configure --> CICS Resources  began deleting and re-adding all of our definitions successfully.

Once that was done the CICS region was stopped, restarted, and we were able to verify ESTABLISHED connections to the dB via netstat (netstat -an | grep <port number>).   And were able to login to the Mincom Desktop from the front end....HAPPY DAYS!!

Of the 4 modifications we made above, to my limited knowledge of CICS, it doesn't seem as if any of those would have fixed the problem, so I'm anxious to put up another region and instance to see if we can re-create the problem.

Thanks again for your help!

 

cag

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close