×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Connecting to Samba domain member using WinXP errors

Connecting to Samba domain member using WinXP errors

Connecting to Samba domain member using WinXP errors

(OP)
I have a domain set up using Samba 3.2.5 with an LDAP backend (Debian Lenny)

I can join a Debian Lenny machine to the domain, and browse the resources on that machine using a WinXP client (not on the domain). All works fine.

I can also join a Ubuntu Jaunty machine to the domain, and a WinXP machine to the domain. Again, all works fine.

The problem comes when joining a Debian Etch or a RHEL 5.1 machine to the domain.

Using "net rpc join -U username" joins the machine to the domain, and "net rpc testjoin" confirms it is successfully joined.

Using "smbclient //machinename/sharename" allows me to browse the resources on the joined machine. But trying to browse it using a WinXP machine will not work.

The error that is seen on the WinXP machine is "There are no logon servers available to service the logon request". In the logs on the domain member, the error is
"domain_client_validate: unable to validate password for user username in domain WINXP to Domain controller PDC. Error was NT_STATUS_UNSUCCESSFUL".

There seems to be a few people having the same troubles judging by a google search, but none of the forum entries have a solution to the problem.

Any ideas?

Thanks
Sean

RE: Connecting to Samba domain member using WinXP errors

Have you actually gone through the process of joining the domain on the XP system?  From your description, it sounds like you've only joined the domain with the Debian and RHEL systems.

Happy Linux Guy
http://happylinuxthoughts.blogspot.com/

RE: Connecting to Samba domain member using WinXP errors

I'm a little confused too - is the Windows XP workstation joined to the domain?

If it isn't, that's normal behaviour. The only exception is if you are using a username and password that exists locally on the machine not joined to the domain. In that case it will let you browse. Otherwise you'll be denied access.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close