×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

VMware permission on vmdk

VMware permission on vmdk

VMware permission on vmdk

(OP)

VMware server 1.0.4 on Linux rhel5.

I was testing gparted LIVE for another task, thought I would use VMware. Everything goes well, but after any gparted (like writing a partition) my VMware cannot boot after partitioning /dev/sdb (I boot from /dev/sda:

Aug 31 11:23:57: vmx| Config file: /vm/testdebian/Other Linux.vmx
Aug 31 11:23:57: vmx| DISKLIB-FLAT  : "/vm/testdebian/Other Linux-2-f001.vmdk" : failed to open (38): AIOMgr_Open failed.
Aug 31 11:23:57: vmx| DISKLIB-DSCPTR: Failed to open extents for descriptor file in normal mode
Aug 31 11:23:57: vmx| DISKLIB-LINK  : "/vm/testdebian/Other Linux-2.vmdk" : failed to open (Insufficient permission to access file).

I've tried to delete and readd the virtual disk.  I tried it with cfdisk and it does the same thing.

It isn't permissions, I am running as root and the .vmdk has the same perms for sda and sdb.  If I remove sdb from VMware it can boot from sda.  If I add it, it works, but after cfdisk or gparted it fails.

If it isn't file permissions, what could it be checking?  I don't (physically) have a /dev/sdb but this is virtualized so does it check that?  Are there permissions embedded in the partition table?

I've worked with this version lots, so I am generally confused.


  

RE: VMware permission on vmdk

(OP)
Well, just tried it on vmware server 2.0.1, gparted works fine.  I guess it is some anomaly in the earlier version...
 

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close