×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Configuring a trunk between 3COM 4500 and Cisco 3750G
2

Configuring a trunk between 3COM 4500 and Cisco 3750G

Configuring a trunk between 3COM 4500 and Cisco 3750G

(OP)
I've searched the web and forums and can't get an explanation as to why this isn't working. Currently everything (switch IP addresses, users, servers, etc) are all on the default Vlan (That's the way it was setup before I got here and I don't like messing with 3Com switches so I haven't had time to take them off the default Vlan). My goal is to setup Vlan 2 as the management Vlan for all network equipment and eventually get everything off the default vlan.

I am trying to get a trunk setup between a Cisco 3750G and 3Com 4500 SuperStack3. This is just a test for right now because the 3Com that is in production is a 3Com 4200G.

 Here is the setup. For easy reference I've made:

    * A = PC on Vlan 2
    * B = 3Com 4500 Layer 2 switch
    * C = Cisco 3750G Layer 3 switch
    * D = PC on Vlan 1

Picture is in the attachment or can be found here:
http://kendrickcoleman.no-ip.org/images/stories/3ComCisco/network.JPG

On the 3750G I have tried these configs

interface Gi1/0/5
switchport trunk encap dot1q
switchport mode trunk

Also Tried...

interface Gi1/0/5
switchport trunk encap dot1q
switchport mode trunk
switchport trunk native vlan 1
switchport trunk allow vlan 1,2
switchport nonegotiate

On the 3com I have gone through the WebGUI (because i don't know 3Com CLI stuff) and done the following
Device -> Vlan Interface -> Create -> Vlan ID = 2, Manual IP = 192.168.2.30
Device -> Vlan -> Create Vlan 2
Port -> Administration -> Setup -> Click on Port 5, change the Link Type to "Trunk" -> Hit Apply
Port -> Vlan -> Modify Port -> Port 5 now says "Not Available for selection", hit the "Tagged" radio button, click on Port 5, Click all VLANs -> Hit Apply

Now if I go to Device -> Vlan -> Port Detail -> Click on Port 5 it shows "Untagged member of VLAN(s)" =1, "Tagged member of VLAN(s) =2-4094

So in my mind everything should be setup correctly on both ends, but the results show as if it's just an access port and not a trunk.

I've tried different variations of it all and i always end up with the same results:
From the 3750G (C) console, I can ping the 3Com 4500 (B)
From the 3750G (C) console, I can ping PC A
PC A can ping the 3COM 4500 (B)
PC A can ping both Vlan IPs on the the 3750G (C)
PC A CANNOT ping PC D
PC D can ping both Vlan IP addresses on the 3750G (C)
PC D CANNOT ping the 3Com 4500 (B)
PC D CANNOT ping PC A

 any and all help is very appreciated  

RE: Configuring a trunk between 3COM 4500 and Cisco 3750G

I've actually done something similar to this, think it was setting up etherchannel from a 4200g to a 3650. I'll check the config when I get a minute.

From memory I had issues due to the terminology used on the 3com. Tagged = trunk in cisco speak iirc.

If you do a show int trunk on the 3750 it will certianly tell you if it thinks it's trunking or not.

RE: Configuring a trunk between 3COM 4500 and Cisco 3750G

(OP)
so i figured it out last night. this is a brand new, out of the box 3750G. I guess I got to far ahead of myself and forgot the one simple rule when configuring anything with Layer 3. 'ip routing'

as soon as i put in that command, PC A can ping PC D, and vice versa.

Now the only problem is that PC D cannot ping the 3Com4500.
I believe this is an ACL problem because it won't connect or ping if it's on a different VLAN.

I've tried setting up an ACL in the 4500 saying
permit 192.168.2.1 0.0.0.255
permit 192.168.3.1 0.0.0.255
and it's still not letting me ping or connect to it.

If I add a VLAN interface for Vlan 1 (ie 192.168.3.30) on the 4500, then I can ping the 4500 on both Vlans.

Not to sure what's going on, but I want to set the switch up to be accessible from any internal ip address, 192.168.0.0/16, but only have one Vlan interface IP address.

RE: Configuring a trunk between 3COM 4500 and Cisco 3750G

Looked back over my configs, looks like I gave up on the trunk and left the 3com without a management ip. Probably due to time pressures.

PCA will not ping PCB without a default gateway that knows of a route to the other VLAN.

PCB will not ping PCA without a default gateway that knows of a route to the other VLAN.

What I'd would probably do is stick as per your diagram a VLAN interface on each VLAN as the default gw, ensure ip routing enabled and you should be able to ping.

Ok I think you've done all that but the part you are missing is I think:

You can not ping the 3Com without a managment ip on it so ensure this has a an IP and a default gw set on it so you can hit it from either vlan.

In the end you need 3 VLAN int IPs, 1 for the 3Com and 2 for the 3750G.

If I'm missing something (maybe the point) please clarify what your end game goal is :).

RE: Configuring a trunk between 3COM 4500 and Cisco 3750G

(OP)
after lots of reading, I have found out that you MUST have the Management IP address of a 3Com switch located on the Default Vlan. which is completely ridiculous IMO.

once that IP address is set on the default vlan (ie 192.168.3.30), then you can access the ip address on the other vlans, 192.168.2.30.

after adding the 'ip routing' command on the 3750G, routing is working and both PCs can ping each other.

thanks for the help!

RE: Configuring a trunk between 3COM 4500 and Cisco 3750G

To my knowledge VLAN 1 has always been the management VLAN on 3Com switches and can't be changed, and is mentioned in the docs.

....JIM....
 

RE: Configuring a trunk between 3COM 4500 and Cisco 3750G

(OP)
i'm a cisco guy. so i dont have any docs or previous knowledge. thanks!

RE: Configuring a trunk between 3COM 4500 and Cisco 3750G

I think that the 4500 use the same software as 4200 and 5500 then you can use the command management-vlan vlanid to set the management vlan

You may also have to use "port trunk pvid vlan vlanid" on the interface you are configuring

RE: Configuring a trunk between 3COM 4500 and Cisco 3750G

(OP)
Faithless, I can't find the management-vlan command in the general view <hostname> or the system view [hostname] on the 4500.

I have 2 4200g switches on one floor and 3 4200g switches on another floor that are in production. I want to do a few things with those some weekend. I just checked and the 4200g has the management-vlan command in the system view. I'll also need to play around with the 'cluster' method. If I could have one IP address to manage all the clustered switches, it would make everything alot more manageable. I've looked at the 4200g guide, and it seems like clustering them is an absolute nightmare and not very straight forward on how to do it. I guess I'll have to play around with that on a weekend.

Thanks for the input. greatly appreciated!

RE: Configuring a trunk between 3COM 4500 and Cisco 3750G

Wasnt sure about the 4500 have nevered used them myself, currently have 5500g and 4200g and some older 3com switches.
We are abou to switch everything to 4800G.

I havent had the need to cluster my 4200G, but my 5500G used dedicated stacking module on the back.

You should be able to have 1 IP per cluster and manage it that way, with the 5500g you tell which switch you want as 1,2,3 etc or you can set it to automatic.

 

RE: Configuring a trunk between 3COM 4500 and Cisco 3750G

Hi FaiTHLeSS,

I´m looking for user opinions about the 4800G. From spec sheet it looks really nice. Do you already have some practical experience with it?

RE: Configuring a trunk between 3COM 4500 and Cisco 3750G

Hi Kinnie

We deployed  around 40 4800G a few weeks ago, mix of 24/48 ports and also the fibre based switches, some are in stacks too, they are also all PoE models, but yet we have little PoE devices hopefully looking into that next year.

Coming from using the 4200G and 5500G before hand there wasnt that much of a change to the switches, just had to watch out for some of the commands are different now, kinda the big one that caught myself from a pre-planning stage to configuration stage is they had change the port numbers on the front on the switch, it no longer goes 1-12 on the top then 13-24 on the bottom. It starts 1 bottom left then 2 top left then carries on that way.

So far the swtiches have been good and havent had any problems with them.

If you are going to be running PoE try and work out how much power you need unlike Cisco you cant change the power modules for bigger versions your stuck with a power budget of 370W by default only way to get more power is to by the RPS device but that takes up more rack space.

RE: Configuring a trunk between 3COM 4500 and Cisco 3750G

Hi,

thanks for the information. We will exchange many of our switches. We will probably sell all of our old ones.
I´m asking myself whether I can use those "old" SFP modules with the 3Com 4800G? Having some original Cisco and many HP flyinh around. I guess, they are all wrong coded?
 

RE: Configuring a trunk between 3COM 4500 and Cisco 3750G

We had older 3com SFP that we used in 3800 series and 4200g series switches they worked fine in the new 4800g series no problem. Unsure if non 3com branded SFP will work.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close