Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here


Unified Communicator Express - Failed to Find ICP Problem

Unified Communicator Express - Failed to Find ICP Problem

Unified Communicator Express - Failed to Find ICP Problem

This is the first time posting here so apologies if I miss something out.

We have a selection of Mitel 5312 handsets running off a 3300. When I log onto the switch it shows the following Release level: 4.0
Active Software Load:
Platform: CX, 512MB of RAM.
The version of Unified Communicator Express we are trying to work with is
PCs are running Windows XP with SP3 installed. .Net Framework (v1 - v3.5) is installed and fully patched.

The initial install went fine however the majority of our systems encountered a problem on restarting the PCs or even just exiting and re-opening the software.

When the software starts we get the error message "Failed to find ICP. Please verify the IP address".

When I go into UC settings and examine the profile set up everything looks fine. The ICP IP address is correct as is the account username and password. In fact it hasn't changed since the program installation when it worked fine.

We can ping the ICP fine from affected PCs and no changes have been introduced in the 5 minutes between the initial install when it connnects and restart when it fails.

I am completely stumped as to why it should work on install and then break afterwards.

Any help in trying to get this fixed is greatly appreciated. If I have missed something please let me know.

Thanks in advance


RE: Unified Communicator Express - Failed to Find ICP Problem

check the FAQ on UC Express. in there it mentions scenario's similar to yours. maybe you'll find some answers there.

RE: Unified Communicator Express - Failed to Find ICP Problem

Even though you can ping the 3300, are you sure you have unlimited access to the 3300 from a PC?
Routing between the two networks is performed by what?
Had a customer with a similar problem and he found out that his router was the problem!
I think you need .net 2.0
Also make sure you have HCI/TAPI in the phone COS...
LDAP TCP port 389?


You can't believe anything you read... unless of course it's this.

RE: Unified Communicator Express - Failed to Find ICP Problem

Hi Dave and MitelPassion,
We have a couple of PCs that are still working. All PCs worked when the software was first installed. It was only after either a reboot of the PC or just exiting and restarting the software that it stopped working on most of the systems.

All PCs have all versions of the .Net Framework installed.

There is no router between the 3300 and the PCs. All are on the same subnet. All get their IPs from the same DHCP servers (phones and handsets).
We also since found that if we entered the IP address of the phone on a system that was not working the software worked fine. This is not viable long term as the phones seem to get a different IP address each time they start (DHCP issued by DHCP servers not the 3300 and we can't change that unfortunately).

There does not seem to be a pattern as we find that PCs with the same hardware, one can connect while the other cannot. PCs not working can have different hardware configurations (and network cards).

The PCs are not plugged into the handset PC network socket.

I have read the FAQ and nothing there seems to apply. I tried playing around with the network card settings of a PC that doesn't work (tried all the various flow control settings, full and half duplexing at various speeds).

As I can connect to the admin web interface of the 3300 from a PC which cannot use dn2ip I am guessing that port 80 isn't an issue.

I have verifed the 3300 settings and they are exactly as the IT guide says to set them (no access on the system policy except for the IP Telephones - all which is set to Read Only).

It's really got me scratching my head.

Thanks again for any suggestions you may have.


RE: Unified Communicator Express - Failed to Find ICP Problem

It looks like I may have found what the problem is. Early days but it would appear to be related to our proxy server. On the 2 problem PCS I am testing (there are more but I'm using 2 to start with) if I clear the proxy settings in I.E. they find the 3300.

Weird how for some PCs the proxy settings are not an issue.

I'm now trialing excluding the 3300 IP address and I'll post the results.

I'm surprised that Proxy settings haven't made it into the FAQs of the user/IT guides, maybe I missed it.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close