×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Problem with ZEN App (7.1)/McAfee distribution
3

Problem with ZEN App (7.1)/McAfee distribution

Problem with ZEN App (7.1)/McAfee distribution

(OP)
OK, so here's the situation.  We need to replace our antiquated eTrust AntiVirus (our support contract ran out and we no longer get definition updates) with McAfee VirusScan.  Honestly, I thought the hard part would be removing eTrust (there's no uninstall script so I had to build an app that manually removes the files and the registry keys).  But in fact, the eTrust uninstall runs perfectly; it's the McAfee install that seems to kill the machine.  

We created a custom install of McAfee that runs as a silent install, then we call the install from a ZEN application (force run).  If it runs from Application Launcher/force run, it locks up the machine for about twenty minutes after which it's all you can do to reboot somewhat gracefully, and when it comes back up, McAfee is not installed properly.  If you run the executable outside of ZENworks, it runs flawlessly, taking about 2 minutes to install and then prompts the user to reboot.  

I have these applications chained so that the eTrust uninstall runs first, then the McAfee install runs.  One thing we found is that if we allow McAfee to update as part of the silent install, that's the point where it locks up.  We manually updated the definitions in the package and then took the update option out of the install, and that seemed to work on one workstation but not on others.  It's very strange.

I've also tried first pushing the installation files down to the workstation and then running them locally but that doesn't seem to make any difference.  Like I said, if you run the install directly it works fine but through ZENworks it kills the machine and doesn't install properly.

I've got about 500 machines I need to update and I really don't want to have to do them by hand (isn't that why we got ZENworks in the first place?).  Any thoughts/ideas?  I'm at the end of my rope.  I've never had an application behave this badly before, and I've been building ZEN apps for about 10 years now.

TIA

RE: Problem with ZEN App (7.1)/McAfee distribution

Why don't you just use ZEn to launches the executable rather than try to run the entire application deployment via zen?

Marvin Huffaker, MCNE
Marvin Huffaker Consulting, Inc.
A Novell Platinum Partner
http://www.redjuju.com

RE: Problem with ZEN App (7.1)/McAfee distribution

I want to assume this is an MSI application, and the application object was set to run as an MSI application.  Oh, and you already tested that you can remove the old AV and install a new AV with out rebooting (you didn't saying anything about rebooting so I assume you aren't rebooting in between).

It's been a few months since I built my last McAfee app (and it was in LANdesk, not ZEN ... shuddder).  The process was fairly simple, but I do not remember if the McAfee customization tool created an MST.  I think it was a single executable.

Anti-Virus installs have ALWAYS been a problem with ZEN, and any application management package for that matter (aka, it's not a Zen issue).  It seems to be related to what the install deals with on the OS (not to sure, never looked into it).

To further expand on Marv's suggestion, simply call the AV client installation from either a Post Launch script or a Post Deployment script.  The difference between the two?

The Post Deployment script will launch after the the app has installed (in this case, there will be no actual app).  There is no console, so you do not see what is happening.

The Post Launch script runs as the NAL process ends.  It's a close your eyes a shoot a gun kind of deal.  What happens happens, zen does not tell you if there was a problem, and zen does not care.  It runs what you tell just as it closes the NAL thread for the application.  

Just because Zen isn't managing the MSI with these two options doesn't make it a failure.  The app just wants to be done in a different way.

If all else fails, write a bat file to run the AV client install and run the BAT from an app object.

=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+
Brent Schmidt                    Senior Network Engineer
Keep IT Simple http://www.kiscc.com  
Novell Platinum Partner          Microsoft Gold Partner
VMWare Enterprise Partner    Citrix Gold Partner
 

RE: Problem with ZEN App (7.1)/McAfee distribution

(OP)
Thanks for all the responses.  So far this is what I've found:  These machines also have installed (in addition to eTrust) Windows Defender.  When I run the executable (and yes, it's a single executable that McAfee creates called SetupVSE.exe) manually (outside of ZENworks), it prompts me to remove Windows Defender first.  Thinking this was the hangup, I created an additional app to remove Windows Defender.  Now the apps are chained together like this: Uninstall eTrust; Uninstall Windows Defender; Install McAfee.  This seems to be working like a charm.  I guess it was a matter of finding what McAfee was balking at.  Oh, and I'm still not having McAfee run updates or a scan after install.  The update package I'm pushing down with the McAfee custom build is current, and the updates pick up again after reboot (which the install is forcing at the end).

So it seems to be working as of now.  Thanks again for all the help upside down

RE: Problem with ZEN App (7.1)/McAfee distribution

I had a similar issue to this, It seemed that if you told McAfee to update during the install it would hang the machine for ages, so this is what I have done.

We use ZEN do install McAfee during PC builds, so I created an install using the McAfee Installation Designer for 8.7. then use ZEN to install, then get hold of an up to date SDAT and create a ZEN app that will run as a chained app after the AV install.

I also have policies on the EPO server that will update DAT's, Engines etc upon the first communication.

 

RE: Problem with ZEN App (7.1)/McAfee distribution

(OP)
That's a really elegant solution.  Thanks, I'm going to give that a go upside down

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close