×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

ESXi - VM can't access the Internet (or ping ANYTHING)

ESXi - VM can't access the Internet (or ping ANYTHING)

ESXi - VM can't access the Internet (or ping ANYTHING)

(OP)
I've got a difficulty on an ESXi box.

I've got a Windows Server 2003 VM running on it - and it used to work fine.

There was a power outage yesterday (that lasted longer than the UPS could handle), and now today the VM can't see the rest of the network though WS2K3 thinks it's connected to the network.

We are using VLANs to segregate our subnets, and the VM is on a separate VLAN than the host machine (this used to work).

ESXi host address: 192.168.104.21
WS2k3 VM address: 192.168.107.7

The VM can't ping the host address, or any other physical computers on the same VLAN even (the 192.168.107.* subnet).

Any ideas?

RE: ESXi - VM can't access the Internet (or ping ANYTHING)

Uninstall the NIC in the 2003 instance.  Then in ESXi, remove the nic from the server once it is powered down.  Then reverse this order.  Re-add the NIC in VM and configure it for your VLAN.  Then when the machine boots up, it detect it again.  Make sure the VMTools is up to date as well.

_______________________________________
Great knowledge can be obtained by mastering the Google algorithm.

RE: ESXi - VM can't access the Internet (or ping ANYTHING)

(OP)
Thanks for the reply TechyMcSe2k.

I'm not sure what happened (didn't even try that), but it is now working.

I've been in contact with our network guru (who is offsite), and I think he got into one of our switches and fixed the problem.

I'm not sure what the problem was yet - though I hope to get it out of him, so I can post what happened and what the fix was.

RE: ESXi - VM can't access the Internet (or ping ANYTHING)

(OP)
Ok, apparently there was a change to our switch that allowed the port it was on to be on the VLAN I set it to - that wasn't saved.  The power outage cleared that and when it came back up it therefore didn't work.

He re-added that port the the VLAN and saved it this time.

Thanks.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close