×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

HP Procurve 2824

HP Procurve 2824

HP Procurve 2824

(OP)
I have a new HP Procurve 2824 - 24port

It's plugged into a rack with an old 3com 10/100 and a Gigabit Cisco

I've connected it to both existing switches and get a link light when I do so.

I've patched in some new network points to this switch, but when I connect a client to the new points, it doesn't receive any data

Do I need to do any config on the switch (as it's effectively out of the box)

Or if not, what ports should I connect it to the existing switches on?

Thanks..

RE: HP Procurve 2824

Hi !
Yes I think you'll need to get some RS232 cable and do some configuration :D

Later you could play with it on WEBBASED interface, but I think first you'll need to set up some stuff...

For an easier interface just type MENU in the console :D

 

RE: HP Procurve 2824

(OP)
Ok I've logged in with an RS232 cable and done the following:

Assigned a name, password, static IP addy for the switch and the default gateway as used by all LAN devices.

I've saved, rebooted switch and I've still got limited connectivity when I connect a laptop to any port on the switch

Can anyone help?

thanks

RE: HP Procurve 2824

Based on the information you have provided it makes it hard to diag.
Whats the topology of the network ?
Is there more than one subnet defined on the network?
Do you have a DHCP server? Is it in the same Subnet?
What model Cisco are you connecting it to?

You are getting " limited connectivity" becuase the workstation is not receiving it addressing from DHCP, Meaning the problem lies in the configuration of your switches.  

RE: HP Procurve 2824

(OP)
Sorry should've been more specific:

Only one subnet - Class C - 255.255.255.0

DHCP Server with a range of twenty addys on same subnet

Cisco switch is a Catalyst 3560

Can you advise what port I should connect to Procurve to and from -> Cisco

Thanks..



 

RE: HP Procurve 2824

It sounds like (if the Cisco is configured right) that all switches ports are in a single VLAN instead of using the default VLAN. If that is the case what you will need to do is on the switch port that the HP is connected to on the Cisco is make sure that it is set as a trunk port with dot1Q as the encap type. Then on the HP create the same vlan as what the Cisco has (VLAN ID ) and add the switch port coming from the Ciso to the HP as a "tagged" port in that vlan, with all other ports being untagged in that vlan.

Example

Cisco 3560
Switch Port 24
Switchport Mode Trunk
Encapsulation dot1Q

**Example VLAN 36****

HP 2824
Create VLAN 36 (or whatever it is on the Cisco)
Port 1 (uplink to Cisco) Tagged in VLAN 36
Ports 2-24 untagged in VLAN 36

Hope this helps. If you are unsure of the Cisco commands let me know.
 

RE: HP Procurve 2824

(OP)
If you advise the commands required thanks!

RE: HP Procurve 2824

Telnet (switch IP)
enable

show vlan (you will be able to see what vlan your cisco is using, and what ports are in it)

ciscoswitch# conf t
ciscoswitch(config)# interface fa0/24
ciscoswitch(config-if)# switchport
ciscoswitch(config-if)# switchport mode trunk
ciscoswitch(config-if)# switchport trunk encapsulation dot1q

exit
write mem

 

RE: HP Procurve 2824

(OP)
When I issue show vlan on the Cisco, there are four VLans displayed - only the first one is active

All the client ports seem to be in use on VLan 1 - Ports go from Gio/1 upto Gio/52

Conf t - works fine

interface fa0/24 - get the following error - % invalid input detected at '^' marker

RE: HP Procurve 2824

(OP)
I get as far as 'switchport mode trunk' and get the following:

Command rejected: An interface whose trunk encapsulation is "auto" cannot be configured to 'trunk' mode

RE: HP Procurve 2824

(OP)
Ok I've got all those commands successfully issued and saved

Can anyone help me with the necessary commands needed for the HP Procurve?

RE: HP Procurve 2824

(OP)
Anybody??

RE: HP Procurve 2824

just enter the:

switchport trunk encapsulation dot1q
before entering
switchport mode trunk
 

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close