Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here


Booting a ghosted SCO HDD

Booting a ghosted SCO HDD

Booting a ghosted SCO HDD

I have a SCO 5.0.5 server running on a Compaq Proliant 5500 with 5 logical drives setup on a Smart Array 3200 controller.

Tried to virtualise this machine on our ESX server awhile ago, and took images of each individual drive and then restored them to VM hard drives. Haven't been able to get that to boot so hasn't worked (it's been sitting on our ESX server now for 2 years)

Anyway in the physical server, the first HDD (0) had a couple of bad sectors pop up and SCO failed to boot.

I've taken the image from the VM server, restored it on another HDD, and then put that into the server in HDD(0)'s place and reconfigured the array so that its all OK from that side.

I believe when I first imaged the drive to transfer to the VM, I didn't do the drive, instead did the partition so missed the boot up info.

If I just try booting normally, with no boot disk - it just comes up with
not a directory

boot not found
Cannot open
Stage 1 boot failure: error loading hd(40)/boot

I have boot/root disks for this server, however I can't get past boot process (it dies JUST before INIT SINGLE USER MODE) saying  PANIC: exit - cannot exec /etc/init (PID 1) 0x00000200

Using the bootdisk and then at Boot: typing hd(40)unix = That doesn't work - I'm assuming I need to LINK the BTLD drivers for the 3200 Smart array.

I have the BTLD for that and when I tried to link it =
defbootstr disable=ida link="ida cha" hd=ida0 Srom=wd(0,0,0)

It will ask for the IDA disk..that works fine, the when CHA comes up:
bootlocore : out of low (below 1Mb) memory!

Getting frustrating now and I have no idea what else I need to do.

If I try putting in the old HDD into slot 0, the array cracks it and says there is no array configuration. So I don't get anything for that. It wanted to do this so I could get the error..but no go.

Can anyone be of any help?


RE: Booting a ghosted SCO HDD

moving openserver images (or even hard drives) around can be a real pain if you change the hd controller (ie raid -> vm WD)

the easiest is to do a new installation of 5.0.5 in the virtual machine and then restore a backup of your data/applications.  do not restore /etc or /stand.

5.0.5 works just fine in a virtual machine.


RE: Booting a ghosted SCO HDD

Thanks for the tips, at the moment i'm trying to get the original server running...

problem is I don't have the original 5.0.5 media which doesn't help.

RE: Booting a ghosted SCO HDD

OK Have tried a number of things and failed miserably.

Although I have the 5.0.5 media now.

I have one idea now, i'd just like thoughts on whether it would actually work or not.

Raid array is setup as per OP.

If I do a sco reinstall onto the 1st disk, what are the chances of configuring it to read the rest of the disks in the array - that were setup on the old install?

I have another sco box built up now, went to restore a tape to only find that the backup is incomplete.

I want the data off the rest of the disks in the system.


RE: Booting a ghosted SCO HDD

How many physical disks were in the original RAID array?  How were the logical drives configured, as RAID1?  RAID5?  Across all of the disks?   


RE: Booting a ghosted SCO HDD

Thanks for the replies, they was no raid setup..each physical drive was a logical drive

but its all OK now, we ended up doing a sco install onto a new box and then (luckily) found a complete backup tape and restored everything.


Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close