Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here


IBM eServer x232 No CD Boot

IBM eServer x232 No CD Boot

IBM eServer x232 No CD Boot


Hey...first time in this forum, so, Howdy :)

I'm having a weird problem.  I have an older IBM eServer X-series X232 that we decommissioned at work, and when it was decom'd it worked fine, but sat in the corner of a server room till I picked it up rather than recycling it, since I do webdev at home, and figured it would come in handy for a testbed server.

However, no matter WHAT I tell the BIOS, the system always ignores the CD drive, and the Setup and Installation disk in said drive.

I've gone as far as setting all four boot devices to "CD-ROM" and disabling PXE/Netboot, and the result is always the same, I get ye-old IBM No OS screen, then hit F1, it tries to boot from PXE, fails, then gets stuck in a loop:

i9990301 disk failure or disk reset failed

Which may make sense, since I think I was told that the drives were wiped when it was decom'd.

However, nowhere in the procedure, EVER, does it handshake the cdrom for the setup/installation disk.

I can't see the hardware randomly 'dying' when its been sitting innocently undisturbed in a corner.  Do any of you have any suggestions?

Thanks in advance.

RE: IBM eServer x232 No CD Boot

I have, on occassion, slipped a dvd into an older machine and wondered why it wouldn't boot.  So, the first thing is to make sure the setup disk is a cd. You could also try just burning a quick linux iso from your choice of distros and see if that boots.   

RE: IBM eServer x232 No CD Boot

Thanks Maultier,

I had thought of that actually and doublechecked my media, I have a few different distros floating around on various media so I doublechecked.  I should update too.

I was able to get this working, but the fix is unusual, I'm not sure how this became a problem.

It seems that I have to completely restore the bios to Default settings every time I unplug/uncable the Cdrom drive PERIOD.  If I, say, take the drive out, and unplug the power, then plug the power back in, the IDE channel is unbootable forever after, until I reset the BIOS completely to defaults.

Same with the Ribbon cable.

Which is odd, since the BIOS can ID that the drive is there just fine, before the reset, after the reset, it actually won't find the CDROM at first, until you shutdown and Cold Boot.

But, at least it works now, hey :)

RE: IBM eServer x232 No CD Boot

probably you have already done the right things,

but I should be sure of the following:

IBM Servers (many) have a strange menu for boot sequence:

in the BIOS main panel, you see a point as Startup Options:

when you enter here, it seems there is a sub-menu,
first row seems the title and above rows the choiche:

instead the first line is not the title but the first choiche, (there is a bullet) and you have to press enter
for real boot sequence setup.

The lines following the first, are for special use:
restart options, ecc.

I hope this may be useful for you,


RE: IBM eServer x232 No CD Boot

I'll check it out when I get home tonight Victor, and appreciate the input, the way those menus are laid out, its entirely possible I whizzed right by it in my initial setup attempts.


RE: IBM eServer x232 No CD Boot

Nah I see what you're talking about Vic, that wasn't it...its working now with the bios reset...at least I kind of know what to do now if that happens again, it should be alright.  Thanks again for the replies :)

Telecom Analyst, FOI.\\\\_______________

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close