×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Permission Denied

Permission Denied

Permission Denied

(OP)
Hello everybody,
  I am not sure whether I have understand the security mechanism which MTS adopts, when installed in an NT server. Here is the situation,
(*) I have NT Server (SERV1) in a domain DOM1.
(*) All the NT workstation user's are authenticated by the domain controller in DOM1, before they log into the NT workstation.

(*) All the (biz/data) components are installed in MTS on SERV1.
(*) I have disabled the Authentication Check.

(*) When I tried to run my application in NT Workstation, it was working just fine.

(*) Then, I tried to log on locally to a local user in an NT workstation. And then I mapped a directory in NT server in my NT workstation by logging in as a SERV1 user. Then the application gave 'Permission Denied' error.

(*) My conclusion now was, all the users who wants to use the components in MTS under SERV1 should be authenticated by the domain controller (DOM1).

I need a better way to handle this situation. I have no idea what needs to be done. Earlier I defined scenario I have right now with me. But for the long run, I want to do this,
* One NT Server
* MTS installed on NT Server
* 100+ users going to user the components under MTS

I need a better mechanism to handle this situation. Could anyone help in resolving this..

Thanks in advance,

RE: Permission Denied

Hi!!

You are not the only one with this PAIN in the ass problem! I have been trying to solve this problem for more weeks now but it seems like no one knows how to solve the problem! Maybe its because there is no solution! But it would be nice to know if that is the case so I dont have to waste more time on this issue!

Ill notify you if I find a solution!

Regards

Nikolaj

RE: Permission Denied

Create a user with Admin rights. Eg MTSAdmin. And have all the packages including the system package run under this account. Let me know if this does not work.

-GJK

RE: Permission Denied

What do you mean by "Run under"????

If it is what I think I dont think it will work, because it is not the components that are denied access to the Server but the creater, in this case a client that is NOT connected to the server!!

My problem is that Im able to create the Object on the server but as soon as I try to access some of the  Interfaces I get the "Access Denied" Error!

I hope my problem is a bit more clear!

Nikolaj

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close