×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Something is re-writing SPFILES

Something is re-writing SPFILES

Something is re-writing SPFILES

(OP)
Hi guys,
I am not getting an answer from the people who are supposed to give us support, so I thought I would ask here.

I am trying to create a setup system for our helpdesk so that they can build (and rebuild) a number of Goldmine undocked laptops - with a lot of customisation.

For some reason, during the install process, the Goldmine installer adds a database called "upgrade1". I do not know where it gets this from, but this is in addition to the  correct one. This happens on all of the installers that I create.

No problems, as part of the install process, I create an OSQL package that corrects the file code (DIRCODE) in SPFILES and removes the erroneous entry.

And this is where the mystery starts. On my PC (Windows XP SP2) this works like a dream. On the Vista laptops, it re-writes the "upgrade1" entry. Odd, I thought, so I ran a trace just to make sure that it was Goldmine and not Windows somewhere. Sure as eggs are eggs, there are 3 lines looking for U_DIRPATH = another installs DIRPATH, and if it doesnt find it, it inserts it to SPFILES.

I have created a sproc to search all tables in the DB looking for "upgrade1" and "GOLDMINE" and the only place it exists is in the SPFILES.

Please help - I'm going round the twist here!

BTW, this is a completely fresh install - no shared system tables

thanks

 

RE: Something is re-writing SPFILES

(OP)
Sussed it:

There was an entry in the gm.ini that was looking for the incorrect database and DBalias. Gawd knows where it got it from, but as soon as I altered that, it worked fine.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close