×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Vmware+Terminal Services+Local Com Port

Vmware+Terminal Services+Local Com Port

Vmware+Terminal Services+Local Com Port

(OP)
I am trying to connect a device through com port and use on terminal services but am having a few problems.

Details:
1. running 2003 terminal server on vmware esx
2. local computer running 2k/xp
3. application that runs great on the 2003 terminal server
4. receiver device that connects through a local com port on the computer

I have checked everything under the local resources tab to enable on the rdp shortcut, serial, disk drivers, printers, smart cards.

However the software running on the 2003 server, does not detect the receiver.

I think it has something to do with the way the com port is setup inside vmware.

What is the trick?
 

RE: Vmware+Terminal Services+Local Com Port

(OP)
I had a random thought that for some reason when I log into terminal services and try to access the com port that it is trying to use the com port on the server instead of the client one.

I think I need to change a setting to look like \\tsclient\com1

Correctly asked questions will receive a better answer.

RE: Vmware+Terminal Services+Local Com Port

(OP)
Ok I am correct, about my thoughts. The com port is not being redirected to the computer using rdp to connect to the terminal server. I hooked up the com device to the vmware server and the program automatically detected it.

So I am sure it's vmware related, any ideas?

Correctly asked questions will receive a better answer.

RE: Vmware+Terminal Services+Local Com Port

(OP)
I have fixed it, very very interesting.

I ran this command when logged onto the terminal server:
change port /query

it showed that the com1, and com2 ports were not being redirected: com1=/device/serial0 instead of saying com1=xxxxx\tsclient\com1

I used these commands to fix it:
change port /D com1
net use com1 \\tsclient\com1

I created a login script for the people that use that server and it works beautifully and allows multiple users to access it and work with no problems.

Correctly asked questions will receive a better answer.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close