Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here


Problem after reinstalling clipper 5.3 - can't build

Problem after reinstalling clipper 5.3 - can't build

Problem after reinstalling clipper 5.3 - can't build

Hi folks, some years ago, I wrote a program in Clipper which I use for my job every day. Recently, I wanted to reinstall clipper and make some changes to the program. It is a few years since I have done so and I have changed PC's since then. I am running Windows98SE as I find it is best for running my DOS applications.

I re-installed clipper and copied my .prg's across to make modifications but when I try to build, I got a message C3007 Can't open #include file 'fileio.ch'

I have confirmed that the autoexec.bat has the correct environment settings but could not get the compiler to find the includes so I changed the .prg to include the full path. This has sorted that problem out and the .obj's have all been built OK but I now get the linker error #4008 file (exospace.lib) Can't find indicated file.

Where am I going wrong? Im tearing my hair out and I have so much less these days anyway. I can't seem to find any help in the manuals. Please help. Thanks, Steve.

RE: Problem after reinstalling clipper 5.3 - can't build

You need to check the 'set' environment from within the dos window.

If in doubt, take the statements from the autoexec.bat and paste them into a new batch file and run that before you compile and link.

The paths in question are probably:




Keep Smileing

RE: Problem after reinstalling clipper 5.3 - can't build

Hi GriffMG, I have tried starting caci.exe from a batch file which included the SET LIB etc statements to no avail.
I really can't understand it, I had used clipper for years and never had any problems. I'm sure I was using win98 back then too. It's driving me mad trying to get it to work.

Any other suggestions?


RE: Problem after reinstalling clipper 5.3 - can't build

To be fair, I haven't actually compiled much in real Clipper for a while, my last commercial app having been converted to xBase++ some time ago.

That said, why not use a batch file like the one below to compile a 'hello world' applet and work upwards to your program from there:



I drop the above into a batch file called mk50.bat, then call it like this:


mk50 myprog

See where you get from that, my clipper is all in a folder called C:\lang\cl50 so you will need to point your code appropriately.



Keep Smileing

RE: Problem after reinstalling clipper 5.3 - can't build

What are you using to compile & link.    Do you use a batch file to drive the process.   Where is the fileio.ch located?
My networks guys used to change the maps around from time to time & I would have to chase down the issue.  I ended up hard coding the path to the various lib's & ancillary OBJ's in my COMPILE.bat to ensure that I could always find the needed source code even if my mapping changed on the network drives.  This sounds similar, if all of the needed source is available then it's just not pointing to it properly.   

Jim C.

RE: Problem after reinstalling clipper 5.3 - can't build

Hi Jim, I am using the clipper workbench (caci.exe) to edit, compile and link. The header files, libraries etc. are in the default directories as set up by the clipper install. The autoexec.bat has been modified during instalation to include the SET INCLUDE, SET LIB etc and are all pointing to the correct directories. I could possibly link from the command line or from a batch file and include the environment variables but first I'd have to remind myself how to do it, its so easy to click the 'build application' button and hey presto.... except its not working. The compiler is doing its bit since I pointed to the includes in the source progs and I get my .obj's so its just the linker I need to sort out however, there are 15 modules to link into one .exe
I think it will be something simple - it was working before and I have a full copy of the clipper programs, my .prg's, etc on CD and have tried copying them over but still no luck.

RE: Problem after reinstalling clipper 5.3 - can't build

I noticed from your initial post that you had been using W98, but now you are using W2k or XP maybe?

Look in the autoexec.nt and config.nt, not in the *.bat files.


RE: Problem after reinstalling clipper 5.3 - can't build

Hi David, I am still on Win98. One thing I did notice though is the config.sys file is empty. I was wondering if this was maybe the problem - should there be some config settings there?


Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close