×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

I must be doing something wrong, but what?

I must be doing something wrong, but what?

I must be doing something wrong, but what?

(OP)
Hey all,

I'm trying to Convert existing computers/servers and run them under VMware but apparently the process is breaking down somewhere.

I started with installing Fedora9 Linux on a box and then installing VMware server on it. The install went smoothly (after I installed the necessary Fedora packages) and the VMware server ran great. I converted a basic XP SP3 workstation and ran it on the VMware server and the whole thing slowed to a crawl. I ran top and saw that the VMware server was consuming about 95% of CPU resources. The VM was unusable due to it running so slow. When I stopped the VM Linux was back to full speed. Out of curiosity I did a fresh install of XP, then did all available MS updates and it ran great. I removed the VM, converted the XP workstation again and had the same problem.

I was thinking that maybe it was VMware server so I downloaded and installed the ESXi software. It installed without any problems. I installed the VMware converter on a different machine and had it install the converted VM on the ESXi server. Same problem. Once I start the VM things slow to a crawl.

I built the VMware box out of an Asus mobo running an Opteron CPU. I never saw anything that said don't use an Asus mobo or an Opteron CPU so I'm starting to think I'm doing something wrong but what??? I get the same results every time I use a "converted" machine. I'm trying to do more with less and VMware looks to be something that can help, but I haven't had much luck so far. Any and ALL help would be appreciated!

Thanks,

Joe B

RE: I must be doing something wrong, but what?

Have you checked on the VM guest to see if there is anything running that might take up all the resources?

Also, check for your hidden device drivers in your guest, even if it is a small chance of them causing an issue, it can't hurt to remove them.

CODE

set devmgr_show_nonpresent_devices=1
devmgmt.msc

Copy and paste that into a text document and name it something.bat and run it on your VM guest. It will unhide all the devices not connected to your machine. You just have to go through one by one and remove the old drivers.

Check your processes also and see if there is something causing it to spike. I've not had any issues with my converted machines. Good luck!

Cheers
Rob

The answer is always "PEBKAC!"

RE: I must be doing something wrong, but what?

(OP)
ArizonaGeek,

I ran your batch file and all it does (that I can tell) is bring up the Device Manager for the server. Out of curiosity I looked through the Device Manager to see if it looked any different and I don't see anything in there that shouldn't be there. Was that batch file supposed to do something special to the Device Manager?

Thanks,

Joe B

RE: I must be doing something wrong, but what?

(OP)
Ok, it has to be a driver issue of some kind. I just fired up another "Converted" Win2k3 server and it runs much faster than the first server. Both servers had similar hardware so I don't know specifically what the problem could be, but I'm open to any and all suggestions.

Thanks,

Joe B  

RE: I must be doing something wrong, but what?

(OP)
Yet another thing: for some reason the "problem" VM won't install VMware Tools. When I try to install the VMware Tools on this server I get the initial screen and then nothing else happens. On the other server I can see the VMware Tools icon down in the Task Bar but not on the problem server. Any ideas on how I can "force" the installation of VMware Tools?

Thanks,

Joe B

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close