×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Memo file ..... is missing or is invalid

Memo file ..... is missing or is invalid

Memo file ..... is missing or is invalid

(OP)
This error message is displayed after I issued a PACK command on my open table with index and memo file.

The error is not displayed when opening the table, neither when editing the associated memo field nor when adding a new record.

I tried overwriting the memo file from a working backup copy but it did not solve the problem.

Can anybody help me fix this?

RE: Memo file ..... is missing or is invalid

Since You have already overwriten the memo file from a backup without overwritting the DBF and CDX at the same time, you have effectively stopped any way of recovering the data from the memo file.  If you ever do manage to get it open, The record pointers in the DBF and CDX will be printing to the wrong place in the memo file.

Your only hope now is to reinstall a backup copy of the DBF, CDX and FPT that existed before the Pack command and start from there.

David W. Grewe
Dave@internationalbid.net

RE: Memo file ..... is missing or is invalid

DSALVAGE PROFESSIONAL is a software package that might help -- I suspect you would have to do some manual manipulation of pointers etc.  I don't know for sure, I've never had your particular problem.
--cd.

RE: Memo file ..... is missing or is invalid

(OP)
Thanks for the response guys! :-)
Sometimes we really overlook simple solutions to problems.
In this case for example, I failed to realize that my database
can be fixed by creating a new table with the same structure. Then appending all records from the table with the "partially" corrupted memo file since I can open the table and the contents of the memo field is still accessible.
Thanks for those valuable info Dave. Whew! :-D

RE: Memo file ..... is missing or is invalid

Perform This Check.
Place the database in natural order (no indexes or orders)
Go to the bottom of the database.
Look at the last entries in the memo field and make sure they are for that record.


David W. Grewe
Dave@internationalbid.net

RE: Memo file ..... is missing or is invalid

(OP)
Yes Dave. I checked those records and they're correct.
I'm just wondering, what was that particular "error" in the memo file which caused FoxPro to disallow the PACK command on the memo file considering that it permits access and update to the associated table specially its memo field (its data is correct based on the selective record check I did).
What do you think Dave?

RE: Memo file ..... is missing or is invalid

The last time I saw that error is when a network User (abuser) had the memo file open with a word processor look at it to see what it was and left it open when (she) when to lunch.

David W. Grewe
Dave@internationalbid.net

RE: Memo file ..... is missing or is invalid

If the file still exist, but just isn't usable.  Then, it's been corrupted for whatever reason.  I have this happen to me when a user shuts down the computer w/o properly exiting and at the time, I have an active memo file up. It's not straight forward.  But, I've always been able to repair it because VFP has a repair capability built in. The problem is that it always takes me a while to get to work. You have to delete the data table from the DBC first and make it an independent table.  Then, if you try to do a use exclusive on it, it will tell you the memo file is bad and if you want to repair it. Then, add it back into the DBC.  However, if you had any long fieldnames in the DBF, you have to rename then since they're lost when you separate the table from the DBC. That's why I use standard 10 char or less names.  So, if I separate and re-add a table, I don't have to deal with the loss of long field names.

RE: Memo file ..... is missing or is invalid

I am having the same problem with a Visual Foxpro table.  Some of the memo fields are corrupt.  When you access the table, it is ok.  When you reach certain records you get a fatal exception error (C000005), which I know is because the memo field is corrupt (data from all other records in memo).  Other than creating a new table and appending all but the memo fields into the new table, is there anything I can do?  I have tried DSALVAGE PROFESSIONAL, but it does not work with Visual FoxPro.  Any ideas or suggestions would be greatly appreciated.

Thank you!

RE: Memo file ..... is missing or is invalid

Not to plug any commercial product, but most developers I know who use *any* product to fix files use Stonefield Database Toolkit.  It creates and maintains an "extended" data dictionary with all the info to repair and/or recreate the table header, which is frequently corrupted, rebuild indexes from scratch, and in some cases, repair memo corruption.  The product's roots go back to FoxPro 2.0 for DOS, and has no real competitors in the marketplace.  Go to http://www.stonefield.com for more info.  I am a friend of the author, but it's STILL the best tool out there.

RE: Memo file ..... is missing or is invalid

FYI:  I exported the table to version 2.X and ran DSALVAGE PROFESSIONAL on the tabel, which found no errors.  I imported the table back into Visual and have no errors in it.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close