×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

I can see a Samba folder but I can't access it

I can see a Samba folder but I can't access it

I can see a Samba folder but I can't access it

(OP)
Hey all,

I'm running Fedora 9 with the new core (2.6.25.11-97.fc9.i686). I now have Samba (samba-3.2.0-2.17.fc9.i386) working and I can see my "shared" folder on my Linux box from my XP SP3 computer but I can't access the folder. I've tried User Security and Share Security but no joy. I keep getting a "\\server\share is not accessible" error when I try to connect. I've 777'ed the folder and tried making the owner me and root but I still can't get in. I've Googled the problem and I haven't seen anything. I'm starting to wonder if it's a Windows 2003 domain issue. I even followed the instructions on this page: http://www.redhatmagazine.com/2007/06/26/how-to-build-a-dirt-easy-home-nas-server-using-samba/ and I still wasn't able to access the folder. I haven't used Linux much but I have some implementations I could use it for here at work. ANY help here would be greatly appreciated.

Thanks,

Joe B  

RE: I can see a Samba folder but I can't access it

There are settings in a Default windows 2003 domain (Domain group Policy) that require digital signing always enabled. I also believe that ntlm and ntlmv2 are disabled in the GP as well. I have had to disable those to properly authenticate to Mac\linux\Unix boxes in the past...

Enable digital signing when possible
enable ntlm and ntlmv2 authentication.

I believe that is what I had to do...

 

RE: I can see a Samba folder but I can't access it

Have you checked the logs in /var/log/samba? You can increase the log level to try to figure out where it's failing.

You can also enable userenv logging on the Windows client, it may also shed some light on the issue.

Have you added root to the smb userlist? IIRC it needs to be added to be able to do some tasks. Go to a shell and issue `sudo smbpasswd -a root`. Make sure the SMB password and UNIX password are the same. There are quite a few things that won't work without root in the SMB userlist.

RE: I can see a Samba folder but I can't access it

(OP)
danomac, yeah it's a permission error. Here's what's in the log.smbd file:

[2008/08/21 07:12:04,  0] smbd/service.c:make_connection_snum(1152)
  '/share' does not exist or permission denied when connecting to [share] Error was Permission denied
[2008/08/21 07:12:08,  0] smbd/service.c:make_connection_snum(1152)
  '/share' does not exist or permission denied when connecting to [share] Error was Permission denied
[2008/08/21 07:12:08,  0] smbd/service.c:make_connection_snum(1152)
  '/share' does not exist or permission denied when connecting to [share] Error was Permission denied

One connection attempt gives these three error messages in the log. I checked in log.nmbd and there wasn't anything in there. I tried using smbpasswd to set myself up using my Fedora password, and when that didn't work I tried it with my Windows password. I even included the "guest ok = yes" parameter in smb.conf thinking that would bypass any password requirements. Nope. I even added root to my smbpasswd list 'cuz I read somewhere that I needed to add root to get it to work. What should my next step be?

Thanks,

Joe
 

RE: I can see a Samba folder but I can't access it

for now at least, in smb.conf, set security=user

Quote:

... smbpasswd to set myself up using my Fedora password..
Yes, use those credentials when accessing the share.Set the share options like

CODE

[share]
    browseable = no
    public = no
    writeable = yes
    path = /some-real-filesystem-path
    create mode = 775
    available = yes
    directory mode = 775
And the last bit, is to make sure that the Fedora user account has the appropriate filesystem permission to read/write to that some-real-filesystem-path.  If the local fedora user account can not access the folder locally, samba (acting on behalf of that user) certainly won't be able to access it either.  BTW, the Samba Server forum is forum865: Andrew Tridgell: Samba
 

RE: I can see a Samba folder but I can't access it

(OP)
Hello smah,

I setup my smb.conf file like you suggested. Now when I try to connect to \\IPAddress\share I get a "Connect to..." window. BUT, when I put in my Fedora login name and password this error is still popping up in log.smbd:

[2008/08/21 08:41:10,  0] smbd/service.c:make_connection_snum(1152)
  '/share' does not exist or permission denied when connecting to [share] Error was Permission denied

I even tried connecting as root from my XP machine and I get the same error. As a test I tried to create a file in \share (from my Linux machine) and did that successfully. Then I tried editing the file. That worked too.

Thanks for the help, and thanks for pointing me to the Samba forum. I didn't see it the first time around. I'll move my problem over there and see what happens.

Thanks everyone,

Joe B  

RE: I can see a Samba folder but I can't access it

(OP)
Danomac,

It's still not working. I can see the share from Windows XP SP3 but I get an Access Denied error when I try to open the share. How do I increase the log level for Samba? I'd really like to get this figured out.

Thanks,

Joe B  

RE: I can see a Samba folder but I can't access it

To change the log level, edit smb.conf (mine is in /etc/samba/smb.conf) and look for the 'log level' item. I do believe it defaults to 3. Increasing it to 10 will give you super-verbose output.

Out of curiousity, is there a firewall on the machine?

Also, what's the output of `pdbedit -Lv <user>` (for the user trying to access the share?

Can you access the share from the samba server itself? (Ruling out permissions issues) `smbclient //<server>/<share> -u <user>

This will ask you for a password, enter it and see if it will connect. You'll have to fill in some blanks here and there. smile

Are you on a domain? If so, engjohn's post applies.

RE: I can see a Samba folder but I can't access it

Ugh, the smbclient command should be: `smbclient //<server>/<share> -U <user>`. Typing a little too fast.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close