×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

ASP.NET CR XI R2 problem on Vista PC

ASP.NET CR XI R2 problem on Vista PC

ASP.NET CR XI R2 problem on Vista PC

(OP)
Hi, my ASP.NET 2.0 web app works fine on several windows servers and on my dev vista machine, but on a new Vista laptop it will not run the Crystal Reports. When selecting a report from within the app it pauses for approx. 30 seconds and then instead of presenting the report it redirects the browser to the app's login screen (the start page). The reports themselves when opened up in CR XI R2 on the same laptop run perfectly well, so I suspect access / security issues are behind my problem. I have researched the problem on the web and applied whatever tips I have found already, but the problem persists. For example, I have tried to give full permissions to the Windows\Temp folder to the NETWORK SERVICE account (which is apparently the account that the ASP.NET worker process runs in), and also trapped the line in the code that fails. It is the LOAD method from code below:

rptX = New CrystalDecisions.CrystalReports.Engine.ReportDocument
rptX.Load(strX)

where strX contains a valid path to the .rpt document.

Sometimes this generates an error in the event viewer (for w3wp.exe process), but not always. After granting full permissions to the Windows\Temp folder as described above it actually worked once(!), but I can't get it to work again no matter what I do. As said, I think the problem is down to security / permissions as the code works elsewhere without a  problem, and the report files definitely exist correctly.

I'd be very, very grateful if anyone out there can suggest any way forward with this one. I have since learned that CR XI R2 is not officially compatible with Vista, but it clearly does run OK on it as I can demonstrate. Vista has SP-1 applied on the laptop.

Any ideas? Or things to check?

With thanks, Ian


 
Replies continue below

Recommended for you

RE: ASP.NET CR XI R2 problem on Vista PC

I'd be curious to know what the event log error is for w3wp.exe

Also, I assume you've tried different reports?

Can you create a basic report which pulls only a few records and try it?

Also are you running your app in process or out of process?

Are you using CR Enterprise (Report Application Server)?

It sounds to me like w3wp.exe is being recyled and your app is in process, so all state/session information is lost. A common problem with .Net apps is framgmentation of the large object heap. This fragmentation can cause application recylcing if applicable values are configured in the IIS manager. The fact that it worked once almost insures that it is no longer a rights issue. It almost sounds like pure coincidence that it's only happening on the Vista laptop.

Can you restart IIS and the app and before anyone else logs in, you login from the laptop and run a report right off the bat.

-- Jason
"It's Just Ones and Zeros"

RE: ASP.NET CR XI R2 problem on Vista PC

(OP)
Hi jdemmi,

thanks for your reply. Here are the answers to your points:

* the w3wp.exe error is: Faulting application w3wp.exe, version 7.0.6001.18000, time stamp 0x4..., faluting module unknown, version 0.0.0.0, time stamp 0x00000000, exception code 0xc0000005, fault offset 0x0ec7bd40, process id 0x%9, application start time 0x%10. It doesn't always generate this error, but does so most of the time. Interestingly the ASP.NET application itself doesn't log an error in the event viewer, which it always does it it encounters an error.

* I have indeed tried different reports - all with the same result.

* One of these is as you say a very basic report returning 12 simple records - again I get the same faiure.

* Running in-process - by that I take it you mean within the asp.net worker process? I haven't edited the machine.config at all, so I believe it is running in-process. After I read your posting I tried to edit this file to change it but Vista is not allowing me to do so (how annoying - how to turn that feature off?). Do you think if it runs under SYSTEM then this may resolve the issue?

* It isn't using CR Enterprise.

* I have rebooted the machine, restarted IIS and tried it straight away, but again I just get thrown, after a pause, back to the applications login page, which is the start point.

Please do get back to me to pursue this if you can. I'm intrigued that your inclination is that it's no longer a rights issue. Any things to try, please do fire away!

Regards, Ian





  

RE: ASP.NET CR XI R2 problem on Vista PC

(OP)
OK, FYI I've resolved it after much malarky trying to re-establish my support with BO now that they've become an SAP company - and completely dropped all of their existing support infrastructure on the web (thanks v much!). The solution was to un-install CR XI R2 SP2, and install the Server Install distributable for CR XI R2 SP3. That does it... hope this is useful to anyone out there so they don't have to go through all of the tracing and performance monitoring gubbins that I've been through over the last week. Now if you could just manage to locate the CR XI R2 SP3 download... ;¬)  

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close