×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

dbf to csv to dbf

dbf to csv to dbf

dbf to csv to dbf

(OP)
I need to upload csv data into an accounting package.

csv -> dbf(using Append from csv type delim) -> program checking dbf -> load to main dbase program

To test the setup, I have downloaded a file that imports perfectly, converted into csv , and used Append command to create dbf. The file size gets increased by a few bytes (34 bytes) for a 600KB files and the checking program reports error. I guess I am missing out something. Any ideas???

RE: dbf to csv to dbf

Lots of users like to place commas inside data fields.  The CSV will load into a dbf but the data types of the fields after the user added comma is hosed and will cause errors.

If you can control it,  get a the download as a DBF or SDF instead of a CSV.

If not add a extra column to a CSV import and checks the extera field for data.  If any data exist in the extra field, then you have a user added comma in the data.
 
 

David W. Grewe Dave
 

RE: dbf to csv to dbf

(OP)
Thanks for the suggestion.
I cannot get output as sdf or dbf.
Now , I have progressed a little - the reason why the file shows a few bytes more is that the numeric fields that are blank gets a stamp of 0.000 . The dbase field has the type NUMERIC 17,3. The dbf files that upload donot get this stamp.How can I prevent the files from getting this default value (0.000) when I use append to import the csv file.

RE: dbf to csv to dbf

You can try set decimal to 0 , but I doubt that will work.  

David W. Grewe Dave
 

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close