×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Can't send mail to company mail from AIX

Can't send mail to company mail from AIX

Can't send mail to company mail from AIX

(OP)
Company's mailserver use CommuniGate Pro on Windows OS.

I've configured smtp relay in sendmail.cf. It's OK and result of telnet is below:


bash-2.05b$ ps -ef | grep sendmail
    conv 42712 49902   0 09:09:13  pts/0  0:00 grep sendmail
    root 51586 17358   0 15:58:57      -  0:00 sendmail: accepting connections
bash-2.05b$ telnet 192.168.118.6 25
Trying...
Connected to 192.168.118.6.
Escape character is '^]'.
220 company.com ESMTP CommuniGate Pro 5.1.9 is glad to see you!
^]
501 Unknown command
quit
221 company.com CommuniGate Pro SMTP closing connection
Connection closed.
bash-2.05b$ telnet 192.168.118.6 110
Trying...
Connected to 192.168.118.6.
Escape character is '^]'.
+OK CommuniGate Pro POP3 Server 5.1.9 ready <56098.1213236333@company.com>
quit
+OK CommuniGate Pro POP3 Server connection closed
Connection closed.


But, when i use sendmail or mail command to send to cometoAIX@company.com --> It's alway in mail queue. Don't realy send.


bash-2.05b$ mailq
                /var/spool/mqueue (14 requests)
----Q-ID---- --Size-- -----Q-Time----- ------------Sender/Recipient------------
m5B7Yrx39026       14 Wed Jun 11 15:34 root
                                       cometoAIX@company.com
m5B7i8i39940       15 Wed Jun 11 15:44 root
                                       cometoAIX@company.com
m5B8PVc40384       15 Wed Jun 11 16:25 root
                                       cometoAIX@company.com
m5C1BdU41268       20 Thu Jun 12 09:11 conv
                                       cometoAIX@company.com
m5B8KMF40370       41 Wed Jun 11 16:20 root
                                       cometoAIX@company.com
m5B8Q0318808      196 Wed Jun 11 16:26 daemon
                                       conv
m5B8Q0B37376      196 Wed Jun 11 16:26 daemon
                                       conv
m5BJ10v42336      259 Thu Jun 12 03:01 daemon
                                       cometoAIX@company.com
m5BJ10t37422      260 Thu Jun 12 03:01 daemon
                                       cometoAIX@company.com
m5BJ10G39462      260 Thu Jun 12 03:01 daemon
                                       cometoAIX@company.com
m5BJ10C36470      262 Thu Jun 12 03:01 daemon
                                       cometoAIX@company.com
m5BJ10S48230      264 Thu Jun 12 03:01 daemon
                                       cometoAIX@company.com
m5BJ10r51774      266 Thu Jun 12 03:01 daemon
                                       cometoAIX@company.com
m5BH10M38108      266 Thu Jun 12 01:01 daemon
                                       cometoAIX@company.com


Somebody help me:

1. send mail to cometoAIX@company.com (I'll received mail in Outlook Express)
or
2. use cometoAIX@company.com on AIX to send mail to myself via Mailserver((I'll received mail in Outlook Express).


Thanks alot.

 

RE: Can't send mail to company mail from AIX

clean out the queue

try echo "test mail" |sendmail -v cometoaix.company.com

watch the conversation and see what it gives for errors

look in root's mail for smtp errors

Get syslogging working and look at the info in syslog

Norm

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close