Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here


BCM 50 to 400 VoIP

BCM 50 to 400 VoIP

BCM 50 to 400 VoIP

I have a BCM50 trying to connect to extensions and access a PRI to send and receive calls through the 400. If you make a call from the 50 the 400 shows the VoIP trunk go active but no digits are received the line times out and goes to prime.

If you make a call from the 400 the 50 does not ever receive the call and the 400 never times the call out.

Please advise.

RE: BCM 50 to 400 VoIP

I look at remote package and they were both set to 00 I change to 05.

PRI Access?

RE: BCM 50 to 400 VoIP

I see where the remote package was on the PRI line which changed it for all the lines. It was set to 00 which I changed  to 05 right now.

Should need to do anything on the 50?


RE: BCM 50 to 400 VoIP

No luck 3.6 and 2.0.

RE: BCM 50 to 400 VoIP

Does it have the most recent patches on 3.6? Also, check the IP Trunk routing table and confirm the digits are in there.  


RE: BCM 50 to 400 VoIP

I patched it during this process.

I used bcm_360[1].350_core.08.0631.

Could not find anything newer.

RE: BCM 50 to 400 VoIP

Ok, go to ip trunks and make sure you have the destination digits in there. Then, check your routing table that the line type is public and the its using the VoIP trunk pool. After this, run BCM monitor on both and see if you can see it trying to leave on the VoIP trunk and if it's being recieved?


RE: BCM 50 to 400 VoIP

400 -
    IP Trunks Destination Digits = 3
    Route 007 Pool B (VoIP Trunks) Public
50  -
    IP Trunks Destination Digits = 9 2 4
    Route 007 Pool BlockA Private (Extension)
    Route 009 Pool BlockA Public (Outgoing Calls)

RE: BCM 50 to 400 VoIP

And can you see it leave the BCM50 on monitor? Make sure you add Pri-A in the remote access package and also Pool B. Also, go to the Active VoIP lines and check they are allocated to Pool B?

And to be sure, make sure the two can ping each other?  


RE: BCM 50 to 400 VoIP

The two can ping each other.

Is there a place to config remote package other than on the line itself?


RE: BCM 50 to 400 VoIP

BCM Monitor

Call from the 400 to 50 ext.

    400 active VoIP Trunk with digits
    50 nothing

Call from 50 t0 400

    50 active VoIP Trunk with digits
    400 active VoIP trunk no digits
    400 times out goes to prime and connects call


RE: BCM 50 to 400 VoIP

Ok I found remote access on 400 where is it on the 50?

RE: BCM 50 to 400 VoIP

Configured remote access on both 400 and 50 to include Pool B and PRI-A and BlocA on 50

Still same results with BCM Monitor

RE: BCM 50 to 400 VoIP

That thread is what got me here.
The two will communicate but only the 50 to 400. The connection is a time to prime DN, But sounds good with no feedback.

If you can send me a private correspondence I can probably setup something like that.

RE: BCM 50 to 400 VoIP

We have got a little further on this. Firstly we have added the target lines on the 400 to recieve from the BCM50

Secondly we have found that the 50 has the same extension range as the 400. So, that beeing the case, system restart to make it a different range. Hopfully this will resolve it as its looking up the DN table first.  


RE: BCM 50 to 400 VoIP

Shouldn't the VoIP trunk pool on the BCM 400 be set to private? Your previous post shows it set as public.

RE: BCM 50 to 400 VoIP

So now you can call back and forth to each system with no problem?

RE: BCM 50 to 400 VoIP

No we are stilling working it. Any Ideas?

RE: BCM 50 to 400 VoIP

Here is a text doc I wrote for another guy I work with. It should be accurate but I wasn't in front of a BCM when I wrote it. Hope this help! There is a better way to setup the dialing plan than what I wrote but it will work.

2 BCM 400 4.0

SIP lines

MCDN keycodes on both sides

Site A (Host side) has PRI already setup and will be used to call out from remote site B.

Example using 4 digit DN's

If, when performing the routing and destination codes the system gives an error, it may be due to the DN's of the phone system interfering with the dialing plan. If this is the case the DN's wheather acive or inactive must be changed before that destination can be used. This applies to Dn's that are on a physical port or application port.

example: Cannot add destination code of 3 for VoIP trunks.
Look at active, inactive, or application DN's for DNs starting with 3, and change them to anything else but 3.
To avoid problems with multiple sites use a 4 digit plan. Destination code can be 32 for example (32xx DN's) and will work if the 2 does not interfere with dialing plan on local BCM.

1. Telephony, Lines, active VoIP lines. Click on each line and add it to the same pool group such as "A" and this pool should be assigned to any sets which will be calling across the VoIP trunks to remote site. Telephony, Sets, Active Sets, click on DN, line access, then Line pool access, add "A"

2. If seperate dialing plans example: DN 2xxx one side A, and DN 3xxx on side B

3. Must use CDP with same private network ID on both sides, location code unused, and private DN length

4. MCDN settings check TRO or else the VMail will not hear your voice when leaving a message on remote site.
TAT can be checked but not necessary with only 1 remote site.
5. IP routing: Resources, Telephony resources, then click on IP trunks, then at bottom the details should show up. Add new route with first digit of destination, name description, IP address of remote side, GW type is BCM, GW protocol SL1, VoIP Protocol is SIP, and QOS monitor and TX Threshhold can be left untouched.

Name= To BCM remote
Destination digits= 3 (for 3xxx digits)
Destination IP=
GW Type= BCM
GW Protocol= SL1

6. Telephony, Dialing plan, Routing heading. Add new route, use pool that was created for VoIP lines earlier, DN type private.

7. Destination codes tab. Add destination code. Example: 3 (for 3xxx extensions), normal route is route just previously created which is probably 002, absorbed length has to be 0, no wildcards.

8. Telephony, Lines, Target lines. must add private received digits to allow calls between the 2 sites. Example: Site A extention 2100 needs private received digits of 2100. Appear&ring or Ring only under assigned DN's tab. Prime set and Control set should be 2100.

9. If DID's are used and routed to Remote site B, must have received # from telco at site A where PRi is, then redirect line to 3xxx set.

Site B Remote side

1. Find DN of Voicemail on Site A, Feature 985 so it can be added to forward to VMail.

2. Follow steps above up step 7.

3. To dial the public network through VoIP to site A's PRI add public route, Pool A, destination code 9, absorb length 0. Under Public network, add 1 digit to DN length for default, the add new DN prefixes with a 9 in front and the length should be 1 digit longer as well. This is because Site A hosting the PRI sees the VoIP trunks as remote dial-in from the private network and adding the 9 tells the system to grab an open line from the PRI pool to dial out.

DN prefix= default      DN length= 11 (normally this would be 10 xxx-xxx-xxxx)
DN prefix= 9911         dn length= 4  (normally this would be 3 if 911)
etc.....for 411 9411, 1 91

4. for voicemail to work must go to Applications, voice messaging/contact center. Center 1, external number is DN of voicemail of Site A


RE: BCM 50 to 400 VoIP

If I understood correctly, you are still unable to complete private (4-digit) dialing over VoIP between the two BCM's even after you've added received digits and appropriate routing (set to private) between the two.  If that's the case, another thing to consider is a possible network issue.

If you are using H323:

 - If there are Cisco Routers in the voice network - disable H245 Tunneling on the Cisco routers (both ends).

 - If there is a Cisco PIX firewall - Disable H323 Protocols (both ends).  

Either of the above will cause calls to complete in one direction but not the other.    

Once the private dialing issue is corrected then the PRI issue should be corrected as well assuming the remote access packages and routing are now corectly configured.



RE: BCM 50 to 400 VoIP

    I followed your doc with no success. I have a BCM50 (2.0) and a 400 (3.6).

    The systems are currently in the same LAN. I am working with them here until I can get them to work, then deal with the WAN issues.

RE: BCM 50 to 400 VoIP

Ok, since you have eliminated the network, then this seems like a simple programing error to me.  Can you confirm three things?

1. Are you using SIP or H323 VoIP trunks?
2. At this point, are you able to private dial between the two systems?
3. What is the start DN on each BCM?

I can send the appropriate programing info if these questions are answered.

RE: BCM 50 to 400 VoIP


Cannot dial between - but the system will go to the prime extension from the 50 to 400. 400 can not dial 50 at all.

BCM 50 starts at DN: 400
BCM 400 starts at DN: 221

RE: BCM 50 to 400 VoIP

Should I see digits being dialed on the receiving system?


Start a call from the 50 (see digits in BCM Monitor) to 400 (VoIP line goes active but no digits).

RE: BCM 50 to 400 VoIP

Yes, you should be able to see the digits in BCMMON – If you have an MCDN Keycode, try enabling UIP Trace (if you haven’t already) as that will give you more insight as to what the failure may be.  I can help decipher if needed.  

I apologize if this seems remedial or redundant but I can’t guess as to which thing may be being overlooked.  If more info is needed, I’ll be around.

Programming - assuming you are using a “back to back” LAN configuration:

Digital or IP Set--?BCM 4.0 <---? H323 VoIP --? BCM50 R2-?Digital or IP Set

BCM 4.0 (start DN 221):  
-    Name: “BCMA” or whatever you are using
-    Remote Gateway: Exp IP:  (use the IP address of the BCM50)
-    QoS Monitor: Disabled (can enable later if required)
-    Gateway Type: (select the appropriate remote BCM type BCM from the pulldown)
-    Gateway Protocol: CSE (CSE is required on both 4.0 and BCM50 releases)
-    Destination Digits: 4 (for straight three digit dialing to the BCM50)

BCM400 Routing: Example:
-    Pool x (x = the VoIP trunk pool)
-    DN Type: Private
-    Dest Code: 4

BCM 4.0 Routing: VoIP trunk route should be set to private, destcode should be 4.

BCM50: (Start DN 400):
 - Name: “BCMB” or whatever
 - Remote Gateway:  Exp IP:  (use the IP address of the BCM 4.0)
-    QoS Monitor: Disabled can enable later if required)
-    Gateway Type: (select the appropriate BCM from the pulldown)
-    Gateway Protocol: CSE (CSE is required on both 4.0 and BCM50 releases)
-    Destination Digits: 2 (for straight three digit dialing to the BCM400)

BCM50 Routing: Example:
-    Pool x (x = the VoIP trunk pool)
-    DN Type: Private
-    Dest Code: 2

Until you get successful private dialing between the two systems, you probably don’t want to worry about the PRI tandem.  Remote packages are strictly for tandem routing.  

Tandem Routing Example:  (I wasn’t sure which BCM has the PRI but….


In the above scenario, BCMA should have a remote access package:  

-    for simplicity, do not use 000 but rather 001 or 001.  Add both PRI-A (assuming PRI-A is the pri pool) and Pool x (x= voip trunk pool).  Under the trunk themselves, ensure you enter the “remote access package – 001 or whatever you’re using).  

BCMB should have public routing pointed to BCMA
 -  Under your remote gateway config – add dest digit 9 (for example)
 -  Under routes, add a public route pointing to VoIP trunk pool
 -  Add a dest code of 9

Under Public DN Lengths:  Create or edit Prefix 9 with a length of 12 / if international add 9011 with the appropriate length, etc.  This is to allow 9+10, 9+11, 9+whatever to be sent from the BCM with no PRI to the BCM with the PRI.

Best of success!

RE: BCM 50 to 400 VoIP

I agree lets worry about the PRI Later.

BCM 400 v3.6
DNs: 221 – 624 (only using 2s)

BCM 50 v2.0
DNs: 400 – 639 (only using 5s)

I cannot configure destination code 4 or 5 (ip phones) in the 400 the extension set goes to high. Should I bump the 50 to 700 or 4 digit codes?


RE: BCM 50 to 400 VoIP

Ok, 3.6 --- still, with 3.6, 3.7 or 4.0 - use CSE and not SL1 protocol in your gateway configuration.

To keep it simple - or at least for testing purposes, in the 400 you can change just the 5xx DN's to something else.  Alternatively, you can use a dest code of 8 or something and dial 4 digits form the 400 instead of three digits but that's certainly not optimum.  


RE: BCM 50 to 400 VoIP

The rename of the DNs would be more trouble than it is worth. So I renumbered the 50 to start at dn 7000.

I am getting the same result as before.

RE: BCM 50 to 400 VoIP

So now you have a 4 digit DN's on the 50 and 3 digit DN's on the 400?  The DN length needs to match between the two if you are to sucessfully configure CDP and MCDN (CLID and VM) features.

If both systems are at a 4 digit DN length - can you specify what the "same result" refers to?  The private dialing issue issue or the inability to add the appropriate dest code?

If the former (private dialing) - have you ensured the routing between the two systems is Private and that the Target Lines assigned to each set have the Private Received digits populated?

If the latter (inability to add the appropriate dest code even though the DN's differ between the two systems): In the system where the dest code cannot be entered, ensure there are NO target lines with the conflicting digit.  Also, ensure there is not an access code conflict.


RE: BCM 50 to 400 VoIP

If I understand you correctly: If one system is on 4 digit and one is on 3 digit they will not talk properly. So if I cannot change the 400 to 4 digit dialing I need to get the 50 to a set of extension that the 400 is not using.

Can I disable extension in in the 400 or can they only be change to different exts?

I am only using 16.

RE: BCM 50 to 400 VoIP

Right - you can "jerry rig" CDP to work with different DN lengths on each system however, it's unsupported nevermind that MCDN features won't work at all.  

So - when you go back to 3 digit DN length on the BCM50, you  can't simply disable a DN however you can either renumber the ones that are conflicting.  If each BCM has overlapping DN's - that's not really an issue - UNLESS there is a conflit when trying to add dest codes.  Now, if you are using the template to automatically populate the TL received digits you will have to check for that sort of conflict as well.  

When you get to the Centralized Voice Mail configuration - the following cheat sheet works 100% if followed exactly.

Of course after youve resolved the CDP issue ...

Requirements for using Centralized Voice Mail.

     1. MCDN Keycode must be applied in both BCM's.

     2. A VoIP Trunk or PRI network is in place between the two BCM's.

     3. A CDP (or UDP) is in place and is confirmed working between the BCM's (Private Network)

     4. CDP PNI (Private Network ID) should be the same on all systems involved.

     5. Received Digit Length must be the same number of digits on both BCM's.

     6. DNs between the two BCM must not conflict.   

     7. Routing between the Local and Remote BCM's must be configured.

         Reference items 1 through 7 above in the BCM 3.6 Programming and Operations Guide, Chapter 20 entitled Configuring

         private networks with SL-1 MCDN for more information if needed.   

 B: Specific Centralized Voice Mail Configuration (Local BCM Call Pilot).

     1. Access the Call Pilot Manager.  Click Configuration then System Properties and select the following.   

         a. Enable External Initialization

         b. Enable Redirect DN

         c. Enable Network Transfers

         d. Submit

     2. In Call Pilot Manager, Click Operations; operator settings.  Ensure answer lines is checked and submit.   

         This is required for CVM since the remote site voice mail calls will access the Call Pilot via the Target Line that is set up

         as described in the next two steps.    


     3. In the BCM configure an unused Target Line with receive number which is the Voice Mail DN (VMDN)

          Services; Telephony Services; Lines; Target Lines; Line xxx; Trunk/line data; Received number

     4. In CallPilot Manager, click the Auto-Attendant heading, the Line Administration page appears

          a. For the target line configured in step# 2, click the Change link.

          b. The Lines Properties page appears.

          c. From the Answer Mode list box, select Auto-Attendant.

          d. In the Table/Skillset Number box, enter 1.

          e. From the Number of Rings list box, enter 0 rings.

           f. Click the Submit button.

       Note: This is necessary for Centralized VM whether or not Centralized AA is going to be utilized.   

     5. Configure Voice Mail Boxes for the Remote BCM DN's



 C: Remote BCM:

     1. Configure each DN with a Private OLI.  Private OLI should match the Voice Mailbox # configured in the Remote Call Pilot.

          Services; Telephony Services; System DNs; DN xxxx; Line Access

     2. Set Voice Message Set (Vmsg set) to Y on the Target Line(s) assigned to each Set DN

          Services; Telephony Services; System DNs; DN xxxx; Line Access; Line Assignment; Line xxx

     3. Assign the Line Pool which is used to access the Local System to each DN

          Services; Telephony Services; System DNs; DN xxxx; Line Pool; Add Pool x

     4. Allow Redirect for each DN

          Services; Telephony Services; System DNs; DN xxxx; Capabilities; Allow Redirect - set to Y

     5. Program CFNA (Call Forward No Answer) for each DN.  CFNA field should contain the Local Site Dest code + VMDN

          Services; Telephony Services; System DNs; DN xxxx; Capabilities; Call Forward


     6. Configure Voice Message Center:

           Services; Telephony Services; Telco Features; Voice message Center Numbers; Center 1

         Program the External # with Dest Code to the Local BCM Voice Mail DN



RE: BCM 50 to 400 VoIP

Shoot - I thought of one other "gotcha" for the CDP issue - at least for the calls that attempt to work in the one directon ... make 100% certain that the codecs and payloads match between the two systems.  


RE: BCM 50 to 400 VoIP

I am wondering if the IP trunking on the BCM 3.6 has some compatibility issues with the BCM50 2.0?  I will see if I can find any as I have only used SIP on the stuff I work on.

Also the 3.6 H.323 settings will be different than what I wrote as it was for SIP. Check the IP routing tabs where the H323 settings are and see if they are set right.

Also did you check to see if the ports are are open through the network even though it is a LAN. Check port 1720 for H323 to work.

From you other posts it seems that the calls go to prime after a timeout which means that the active set isn't receiving the digits. The Intercom digits on both sides should be the same length and private received #'s should be the same as the Intercom DN so it will ring on the set.

When you call between the 2 systems are you calling an active DN to test?

Open the BCM monitor and when you dial the first digit to the remote side it will show you the VOIP line in the pool as you dial. If it isn't showing it right away then something is wrong on the dialing side.

We also had a problem with the SIP dialing and realized we forgot the SL1 setting, so for H323 it could be something very simple as well.

RE: BCM 50 to 400 VoIP

Here is the scoop on IP Telephony with BCM 400 3.6 - 3.7 software.

REBOOT THE 400 often!!!!!!!

We have probably had the thing configured right for a week.

So far I have found that if you change the system name (Business Name) you have to reboot.

If you change a target line or extension name you have to reboot.

If you change the business name on the remote side you have to reboot the local 400.

Best way I can put it is configure everything then reboot both systems.

RE: BCM 50 to 400 VoIP

Until 4.0 the BCM is under Billy Gates technology.

When in doubt reboot.

"Ctrl-Alt Del"  Best shortcut feature invented.

Made as a infamous feature by Bill.   

RE: BCM 50 to 400 VoIP

I have found that if you restart the "VoiceNetVoIPGateway" service it will accept any changes and allow the system to communicate with out having to reboot the system.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close