×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Send e-mail Groupwise/API/receipient remains empty

Send e-mail Groupwise/API/receipient remains empty

Send e-mail Groupwise/API/receipient remains empty

(OP)
Hi all,

I'm trying to set up an e-mail using API and start the groupwise message-dialog. All data is visible; except for the receipient.

After using
gwReceipient = gwMessage.Receipients.Add("validadress")
gwReceipient.Resolve()

the value within gwReceipient.Resolved = 3 /* which means resolved */
even displaying gwReceipient.EmailAddress and gwReceipient.DisplayName show the right data.

The e-mailscreen is opened by a "groupwisecommander" using method OpenItem. All works fine, even attachments, but the receipient-field (to) remains empty.

I have only a local groupwise client (7.0.3) installed (no novell here in the building)

Any suggestions?

Regards
Peter

Some of the (Progress ABL/4GL) code below here:

create "NovellGroupWareSession" gwApp no-error.

gWAccount = gwApp:Login.

gwMessage = gwAccount:MailBox:Messages:Add().
gwMessage:FromText = "no-reply@mydomain.nl".
gwMessage:Subject  = "Complaint Form".
gwMessage:BodyText = "Please review the enclosed complaint form".
gwReceipient        = gwMessage:Recipients:Add("peter@mydomain.nl").
gwReceipient:Resolve().  
    
    
MessageId = gwMessage:MessageId.
create "GroupwiseCommander" gwCom no-error.
cQuotes = """".
gwSend = "ItemOpen(" + cQuotes + MessageId + cQuotes + ")".   
GWerror = GWCom:Execute(gwSend,"").

RE: Send e-mail Groupwise/API/receipient remains empty

Not much in the way of developers on this forum. You'd be much better off going to Novell's Developer site:

http://developer.novell.com

 

Marvin Huffaker, MCNE
Marvin Huffaker Consulting, Inc.
A Novell Platinum Partner
http://www.redjuju.com

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close