×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

SQR Debug

SQR Debug

SQR Debug

(OP)
We are currently on PS Tools 7.63 and I am trying to debug an sqr.  I have appended -debughv to my Process Definition Options tab of the sqr I am running because these are the letters that are being used in the program.  I have tried both upper and lower case -debughv.  I have run this numerous times and checked the parameters on the process.  I do not find that the process has the debug parameters appended to the statement.  None of the debug displays print in the sqr.log.  What might I be missing?  The current output destination is file and looks like the following:
C:\sqrTEMP\VoucherUpl
Thanks,
J9

RE: SQR Debug

Where are you adding the debug flags?  

You can add them either in the Process definition which is what it sounds like you are doing... or if you want the debug file dropped to the client and you can run the SQR on the client rather than server, add the -debug string to the end of the SQR flags in config manager (process scheduler tab).  It should not be case sensitive.

Hope that helps.


  

RE: SQR Debug

(OP)
You're right.  I had already added them to the process definition.  So based on your suggestion I've added the -debug to the end of the sqr flags in the config manager:
-iX:\ep753\sqr\ -mX:\ep753\sqr\allmaxes.max -oC:\sqrtemp\sqr.log -ZIFX:\ep753\sqr\pssqr.ini -debug

Is this the correct placement?
Thanks,
J9

RE: SQR Debug

Hi Jean9,

That should work - just make sure you add the flags on the debug part (-debughv) as it won't look at the ones you have set up on the process definition when you use this approach.

Depending on the flags, some of the more generic debug in PeopleSoft SQR's tend to sue the abc and xyz flags - not sure of you wanted these as well.

Hope that helps  

 

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close