Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here


Internet connection good but unable to open web

Internet connection good but unable to open web

Internet connection good but unable to open web

I am unable to open any web site on my laptop as internet explorer doesn't open fully, even though my internet connection shows as being good or very good. I get told that the page cannot be displayed, whichever page I try to open. I've tried changing different settings in network connections, and have tried taking the laptop to a friend's house and trying their wireless connection, and have had the same problem, so I don't think it's the wireless network, but I may well be wrong. Can anyone help on how to get this working again, please?

RE: Internet connection good but unable to open web

More history would be helpful - like when did it stop working/did it ever work, and any changes you might have made to hardware software around the time the problem started. Also, get hold of a copy of another browser (firefox, opera..), install that and see if ti works. Often problems like this are IE specific and other browsers work.

PS. Can we assume your connection is via a wireless router?

RE: Internet connection good but unable to open web

Thanks for the reply. It stopped working a couple of weeks ago, and I've been trying to make it work ever since. It worked fine before that, and another laptop in the house still works perfectly on the network. The connection is through a wireless router. I didn't make any deliberate changes to any software, but I have a security system set up, so I'm wondering if that may have changed something automatically when trying to get rid of a virus. I don't know if that's the type of thing they do, but that's all I can think of.
I'm downloading a copy of firefox now, and will try loading that to see what happens.

RE: Internet connection good but unable to open web

What do you use for security? I've seen McAfee and Norton both prevent access when not specifically configured to do so.

If firefox doesn't work, can you try pinging say www.google.com from command prompt to see if you have a connection. If you can, try using the ip address in the address bar of the browser like http://ip address to see if it will work with direct addresses. If firefox does work, its probably some IE add-on causing the problem - if you've ie7, you could try starting it in safe mode (option from the start menu) as that doesn't load add-ons.

RE: Internet connection good but unable to open web

Hi Domino 3;

Ok, now I work over at Road Runner ISP, and we get alot of calls like this. First of all we need to know if you have a good ip address. A 169. whatever means that you are not connected, but anything other that this is a good one.

Second we need to do a powercycle! And this consist of (depending on a router sequince).....

1. Shut down your pc
2. unplug the powercord from your router (if you have one!).
3. unplug the powercord from your modem.
Note: if you have a digital modem from your isp, then you will need to reset the modem that is behind the modem, in which there will be a small hole that is next to the ethernet port.... use a paper clip and push in the reset button that is inside this hole, wiat 5 seconds and then replug in the powercord and then waite 45 seconds, then plug in the router.

4. Waite 35 seconds and then turn on your pc and see if this would work.

Now if you have any firewalls up like "Norton's" please disable this.

Hope that this works for you.

Email me personally if you have any other questions.....

Eddie -- Maverick2842@sbcglboal.net

PS. I am the new kid on this block!
    Happy New Year!

RE: Internet connection good but unable to open web


Make sure that related services are working, especially the DHCP service. If your computer is assigned an incorrect address for a DNS server (which is either your router/modem or your ISP's gateway), it will not resolve internet addresses even while successfully connected to the internet.

You can check this under Control Panel >> Administrative Tools >> Services.

Also, check in Administrative Tools >> Event Viewer for any services/programs that failed to start or any other related problems.

And meanwhile, open the command prompt (Start Menu >> Run >> "cmd.exe") and type "ping microsoft.com" and "ping google.com" to ping these servers, which are always available; this will tell us if it's a browser problem or something more fundamental.

RE: Internet connection good but unable to open web

Lets start simple and work our way up, eh? Click Start - Run inside here type cmd. In the command prompt you will want to type ipconfig and look at what you're getting for an IP address. If you're getting a 169.* IP address then you're DHCP service is working as expected. If you're getting all 0's then you're DHCP service might be disabled which can be enabled via msconfig by going to Start - Run and type msconfig. Goto the services tab, then scroll down to DHCP service and make sure it's checkmarked. If you have another IP other than all 0's but it's a 169 IP then you'll probably want to run these from the run box in the start menu in no particular order:

netsh int ip reset reset.log

netsh winsock reset catalog

ipconfig /flushdns

ipconfig /registerdns

Reboot and check your IP to see if you're still getting a 169 IP address. If you're not getting a 169 IP address or all 0's for your IP then you'll want to check your routes by first pinging an IP address, in the command prompt type:


If you get replies then try pinging a DNS by typing the following into command prompt:

ping www.google.com

If that replies then we know it's on the software level(IE is to blame)

Try these things out and let us know where you're at.

RE: Internet connection good but unable to open web


If you're getting a 169.* IP address then you're DHCP service is working as expected

Not entirely true... for example, at home, I use a 10. address.  Most routers use a 192.168.* out of the box.


If that replies then we know it's on the software level(IE is to blame)

Or Norton Internet Security.  Or IP filtering.  

Other than that, your advise was pretty good.

Here are the steps that I would take, personally:

1) Clear your temporary internet files in IE
2) In your Cache Size setting, if it's anything above 50, turn it down to 50.  Many people have their temporary internet files storage size turned up so high that the computer spends more time sifting through old pages than actually connecting to get a page.
3) Try going to www.purple.com
4) If that doesn't work, go to a command prompt (Start --> Run --> CMD) and type ipconfig /flushdns
5) Try www.purple.com again
6) If it still doesn't work, from the command prompt do a netsh winsock reset
7) reboot (you will have to after #6) --- in fact, do a complete shutdown and start back up.  This will reset your wireless card.  Just a simple restart doesn't always bring wireless cards out of sleep mode.
8) If you still have no joy, then it's time to dig deeper.  In your command prompt, do a ping
9) If that doesn't work, double-check your wireless settings in your router, make sure DHCP is working properly, try a different wireless device to make sure it works, etc.  If it DOES work, then try ping www.google.com
10) If pinging www.google.com works, then your IP address and DNS settings are OK.  If #9 works, but #10 doesn't, then you have a DHCP problem.  Try opening your browser to   If google comes up in your browser, then your browser is fine, but your DNS is broken.  Check those settings.
11) If you can ping www.google.com but it still doesn't come up in your browser, then ask yourself "How fast is 'page cannot be displayed' coming up?"  If it is saying that instantly, then double check (in IE) Tools --> Internet Options --> Connections --> Lan Settings.  Make sure that "Use a proxy server" is NOT checked.  The only thing that SHOULD be checked there is "Automatically detect settings" (the first box)
12) Additionally, under the Tools --> Internet Options --> Connections tab, either "Never dial a connection" or "Dial whenever there is no network connection present" should be checked.  If it is set to "Always dial a connection", it won't connect wirelessly.
13) Check your windows firewall.  Try turning it off and see if your problem goes away.
14) If you haven't done step #0, you just spent all this time only to find that Norton Internet Security was the culprit. ;)

I do wireless support for hotels.  People who call the 800 number to reach me are *usually* resolved within 5 minutes.  9 times out of 10, clearing the temporary internet files, doing an ipconfig /flushdns and making sure they are NOT running Norton's Internet Security (note: this is not the same as Norton Anti-Virus) solves the problem.

Just my 2ยข
-Cole's Law:  Shredded cabbage

--Greg  http://parallel.tzo.com

RE: Internet connection good but unable to open web

Actually, If you are getting a 169 IP then your DHCP service itself is working but you're not getting an IP from any DHCP server. I know that internal networks use 192. or 10.(Which is what I use on my freebsd firewall/router) but if he was getting a 169 IP the point I was making was that it wouldnt be the DHCP service that is at fault. Just thought I'd clear that up.

RE: Internet connection good but unable to open web

I had a client machine come in that was unable to resolve DNS information. It could ping any IP address from the command line, but not google.com(or any other site). Went through the typical things to resolve like mentioned in this thread. Nothing worked. Finally tried a USB to ethernet adapter and it worked just fine. Removed it and went back to onboard NIC and it did't work. Finally I uninstalled the onboard NIC from the system. (right click My Computer and select properties. Choose Hardware Tab, click Device manager, expand Network Adapters, Right click Adapter and choose Uninstall) Restarted the machine, it reinstalled, and IT WORKED!
Just another thing to try. Hope this helps someone.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close