Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here


set default paper size for printer

set default paper size for printer

set default paper size for printer


I have a little script to add the networkprinters on our clients. The strange thing is that the printers are configured on the server with the setting, default paper size A4, but when the printer is installed on the client, this settings is put to "Letter".

is there a way to specify this in the script?

This is the script:

Set WshNetwork = CreateObject ("WScript.Network")
on error resume next

PrinterPath = "\\server1\HP 1320 COMPTA"
WshNetwork.RemovePrinterConnection PrinterPath, true, true
WshNetwork.AddwindowsPrinterConnection (PrinterPath)
WshNetwork.SetDefaultPrinter("\\server1\HP 1320 COMPTA")

Thank you in advance.

RE: set default paper size for printer

This is not the only problem I find with A4.  There is also Auto Select and Automatically Select.  I don't know which one it is but even when you set the size to A4, one of these changes it back to letter.

RE: set default paper size for printer

so there is no way to specify in the script that the setting needs to be papersize A4?

RE: set default paper size for printer


I have had a similar problem like the one you mentioned. however i was mapping the printer manually.

the problem i think lies with the driver settings on the print server. On the server check the following under the printer properties

-  general tab, Printing Defaults and check the paper is a4.
- Advance Tab -> Paper Defaults is set to a4.
- Device Tab - the trays are set to a4.

this may resolve the issue.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close