×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

DB query issue

DB query issue

DB query issue

(OP)
Ok, I run a series of maps that load some tables, yada, yada, yaday....

The second to last map updates a table successfully.  The last map reads the table updated by the last map and build a report, no variables and pointing to an mdq file.  

As part of the chain of maps executed by the control map the last map always fails.  If I run the map outside the control map it works.  If I comment out all control map map executions but the last one it also works.  Seems like theres a conflict.  any thoughts?

6.7.1
windows

RE: DB query issue

If you're running all the maps from a control map, has the update map committed the data at the end of it's run? What is the last map failing with?

RE: DB query issue

(OP)
It fails with '8' invalid data.  It's invalid because at least one row is required but the select returns 0.

I wondered about the commit.  So, I inserted another runmap without any db connections between the the update map and the select map.  The added just reads a 5mb file.  Same results.

RE: DB query issue

(OP)
The other thing I did to test this was to write the runmap rule as follows

seriestotext(dblookup("select * from table", " -mdq name.mdq -dn dnmame")) + "<nl>now run map<nl>" + run("map", "-ae=logfilename")

Which returned all of the data from the query + the comment + the return code, as shown below.  So it appears the DB is avail for query.

data
data
data
now run map
8

RE: DB query issue

(OP)
must have still been connected without the commit.  instead of running a dummy map I executed this just before running the last map...

dblookup("quit", " -mdq name.mdq -dn dnmame"))

The result was that the last map ran without error.

think that's a little odd.  

RE: DB query issue

Could the problem be with "-ae=logfilename"? - path for the logfile not available?

RE: DB query issue

(OP)
Thought that too.  tried no logfile name and "-ae=path\logfilename".  Same problem.  Thought I had it working before I overrode the log file.

RE: DB query issue

Hello all,

We have 5 instances of event servers running on HP-UNIX system.For each instance two processes should be shown – one Mercator process and one Java process.  

It has been observed that for two instances multiple java processes are shown but there are no problems observed on Event server.Please let us know the reasons and remedy for why this multiple java processes are shown.

The version we are using is Mercator 6.7(306_1EM)

Thanks in advance!!

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close