Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here


Mitel SX-200 ICP .... Auto Attendant / Night Mode

Mitel SX-200 ICP .... Auto Attendant / Night Mode

Mitel SX-200 ICP .... Auto Attendant / Night Mode

Hello there,

Recently our system here suffered a Flash Card replacement, and we're rebuilding from scratch.  Currently I am not sure as how to get our phone system to go in Night Mode where the Auto Attendant would answer and cycle through the Main Greeting.

Before the repairs... main Reception phone to had a button that said "Night", and when we hit this the phone didn't ring and did what it should (went to Auto Attendant Greeting).

I've tried setting up a Phantom extension and forwarding the Main Reception phone to this, but it doesn't even seem to forward at all.  The phone just rings, and rings, and rings no matter what I do.

It could be that the repair guys setup the lines wrong?  They seem to be setup as "Multiple Call INTERFLOW, In/Out"

Any help would be greatly appreciated.


RE: Mitel SX-200 ICP .... Auto Attendant / Night Mode

The "night" button would have been a Feature Access Code. If I remember correctly, you can expand the set in form 9 and program the button as a Feature button.  Alternatively, you can program a speed dial entry to dial the FAC. You will need to look up the FAC in Form 2. FYI - this code needs an additional "condition" digit to use.  I believe 0=day, 1=Night1, and 2=Night2.  Also, the set using this feature needs to have it's COS enabled for this feature.

Alternatively, you can just enable the COS of the set and use the "Blue" key.  This is the Superkey and if you scroll through, you will find the ringing service and can adjust from there.

Insert Witty Signature Here.

RE: Mitel SX-200 ICP .... Auto Attendant / Night Mode

Thanks for the reply paterson!

I just found out that it looks like "forwarding" of any kind doesn't work anywhere in the office.  Looks like I have a larger problem than I though.

RE: Mitel SX-200 ICP .... Auto Attendant / Night Mode

well I still haven't gotten the "night button" to work.  Does anyone else know something else to try?  Even if I put that phone on "Night Service N1" it still doesn't hit the Auto Attendant, just rings and rings and ring.  Phone is setup with a Prime line and 4 Multiple lines which bring to Queue Interflow.

RE: Mitel SX-200 ICP .... Auto Attendant / Night Mode

Need to know more about how the call enters the system and what it terminates to.

Assuming PRI trunks and terminating to an Addtendant LDN you need to program the Attendant night access points in form 19.

If your config is not this, please provide specific details.

Occam's Razor - All things being equal, the simplest solution is the right one.

RE: Mitel SX-200 ICP .... Auto Attendant / Night Mode

Check the option package installed on the system (feature package)....I had the same problem and had to reenter the feature option recordMOC number and MOSS sheet. You get this info from the mitel website under the associated files for that customer. For us it was feature pack 6
Once I did this I was able to put the system on night.

RE: Mitel SX-200 ICP .... Auto Attendant / Night Mode

Metballnut, I think he would have had greater issues than night service if the system was unlicensed.

Hmm like, no phones would work at all comes to mind.

Occam's Razor - All things being equal, the simplest solution is the right one.

RE: Mitel SX-200 ICP .... Auto Attendant / Night Mode

Hey guys,

Thanks for the answers on this.

I actually did manage to get the phones on "Night", but I still don't have my actual button programmed for this.  I set Tenant 2 to be able to set night mode on all the phones (seems to be the only way to make the main phone not ring)

kwbMitel: I'm not quite sure of how to answer your first question.  Our system has 8 analog lines that go into the box.  I can find all my trunks under "Non Dial-In Trunks".  Form 19 seems to be setup, or partially setup (truth is I'm not completely certain).  The system goes extension 2021 on Night1 (only way I could make it do what I wanted), since the 2016 extension would just ring all the time no matter if the phone was on night or not.

metballnut: I don't have any MOSS sheets I don't think. We purchased this entire phone system from Bell Canada, and I do believe that they didn't give us everything that we need.  I do however have a printout of the configuration (seems that it wasn't as updated as I though though), so some configurations are missing.

I had to add in extension 2021 and Busy that out permanently (this is how the phone system was setup before), and since I've done this there's now an error on the box stating that there's a "Minor issue" since that is always down.  Tried clearing that and it won't let me...

Thanks again,


RE: Mitel SX-200 ICP .... Auto Attendant / Night Mode

Ok now I think were getting to the meat of the problem.

You have mentioned that you are using tenanting. Each tenant controls only it's own night service unless control is granted via form 6.

I believe you are successfully switching the night service but only for the Tenant of the phone where you are doing the switching.

By default all tenants are in night 1. This would explain why your trunks are going to the Night1 destination assigned in form 14.

What tenant are your trunks? Do you have a phone that controls the tenant of the trunks (in same tenant or via form 6)

Don't give up yet, i think we're getting there.

(P.S. is there a reason you aren't asking your service provider to help)

Occam's Razor - All things being equal, the simplest solution is the right one.

RE: Mitel SX-200 ICP .... Auto Attendant / Night Mode

Sorry for replying so late.  I usually see the messages when I'm at home, and then I have to wait to come into work to see the forms in the phone system, etc.

ok looks like the trunk is on tenant 1, and the main phone that controls everything is on tenant 2.

form 6: I set up tenant 2 so that it can control everything for the night switching .... this temp fixed my problem.

to answer your "P.S." ... we used to have maintenance through bell, but we lost our funding for that, so we really don't have any.  That's kind of why I always end up here for most things.

Have a great weekend,


Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close