Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Error when installing Cisco VPN Client on Vista

Error when installing Cisco VPN Client on Vista

Error when installing Cisco VPN Client on Vista

I have 2 laptops both running Vista Home Premium. When I try to install the Cisco VPN Client it gives me an error during the install - "Dneinst execution error while installing DNE, returncode- 517799898"


The laptops are a HP DV6000 and a HP DV2000


I have installed the same Ciscon VPN on another HP laptop running Vista Home Premium and it installed without any problems.


I am installing the software from local admin accounts. I found one solution that involved a registry edit but that did not fix it.


Any ideas?

RE: Error when installing Cisco VPN Client on Vista

I encountered a similar error a while back on an HP laptop with Windows 2005 Media Center, turned out to be a bad memory stick, have you disabled all non essential services? if not try that first, then i'd go the memory route, if your system has more than one memory chip i'd try the install under only one chip, finding the culprit chip, if neither helps then see if you can install it in safe mode

"I'm certifiable, not certified. It just means my answers are from experience...not a book"

RE: Error when installing Cisco VPN Client on Vista

Have you tried disabling any security type software, virus scanners and the like and seeing if it installs?

VPN  forum463: Virtual Private Networks (VPN): Virtual Private Networks (VPN):  may be of help.

Are these the Google links you checked out?



RE: Error when installing Cisco VPN Client on Vista

Thank you for the links. I have looked over those links you sent, one of them has my post to the tech forums at Microsft as the top search result :)

I ended up sending an e-mail to Deterministic Networks, the creators of DNE. For all of you who are looking for solutions other than re-imaging, here are some things to try.:

Below is the email we send out to people with Install problems.  So far, it's always worked if people follow each step.  
-------------Begin snippet------------------------------------
First, I need to offer this disclaimer:  DNE is a toolkit that we supply our customers (like Cisco, Microsoft, Juniper, etc) to develop networking products.  We don't control their products or how install is done.  You really should go back to the vendor for support of their products.  
That said:
There  are two  install logs on more recent versions of DNE.  They are located in the %windows%/temp directory where %windows% is the Windows directory on your machine (should be Windows\temp for XP).  The logs are called dneinst.log  and dneca.log.  
There are a few known issues with installing DNE - usually related to one of the following:
1) Permissions - you must have administrative privileges to install any network driver like DNE.
2) Corrupted registry.  Some other products can leave the registry in a state where the installing product loses its install path.
3) A bug in a Windows Update that breaks our ability to read the DNE version in a standard manner.
4) A bug in previous versions of our install script which terminates because of what it sees as a file/directory collision.
5) Leftover Cisco registry keys that may prevent Cisco VPN clients from reinstalling.
6) Leftover inf files from other failed installs which prevent products like DNE from installing.
7) A corrupt operating system.  Microsoft has a bug where an OS can get into a state where it can't install any IM driver like DNE.  Cisco now believes this may be related to another of their products called CTA, particularly when running in conjunction with Citrix.
I also note that a timeout or failure to install a plugin can also be caused by having an open Network Control panel.  
So, here are the steps I usually propose to help diagnose this:
0) Make sure the Network Control panel is not open.
1) Make sure you have admin privileges. If you don't, log in as administrator and try to install again.  If that fails, proceed to (2).
2) Try to install  again.  This will generate the install log.  You might want to rename that file before proceeding to the next step so that we can see what happens on install of the current package (and on the next one).  Note that with really early versions of DNE, there won't be a log.  If this doesn't work, please try an uninstall in case some of the original product installed.

3) Try to Install the DNE Upgrade from our website (lower right corner of the home page).  That will install the latest version of DNE which has circumventions for a variety of OS and even our customers' problems.  Then try to install the original product again.  It will run with a newer DNE if it installs successfully.  If that fails go on to (4).
4) If you see return code -1073741819, this is a DNE install script bug: Older versions of the DNE install script include the following string to execute the install, but we forgot the quotes:
c:\Program Files\Common Files\Deterministic Networks\Common Files\dneinst.exe
So, without the quotes, if there's a file in the c:\ directory called Program (or beginning with Program and a space but not Program Files), this will fail.
It will also fail if there is a file in the c:\Program Files\ directory that begins with Common (and a space but not Common Files)
It will also fail if there's a file in the c:\Program Files\Common Files\ directory beginning with Deterministic (and a space, but not Deterministic Networks) - there shouldn't be.
It will also fail if there is a file in the c:\Program Files\Common Files\Deterministic Networks\ directory beginning with Common abd a space, but not Common Files.  
So, if you can walk this path, look for any 'colliding' file names, and rename them, all should work.  If this is the problem, most likely you have a a file called program in the c:\ directory.

5) Check the registry to see if the key
HKLM\Software\Microsoft\Windows\CurrentVersion\DevicePath exists.  Make sure it includes:  %SystemRoot%\inf.
The data type should be 2 for REG_EXPAND_SZ.
If this is in the path, try the following:
a) Locate dneinst.exe on your system
b) Open a CMD prompt
c) CD to the directory where dneinst exists
d) run the following
dneinst - fixup
When it completes, reboot.  
Try the  install of DNE Update again, followed by installation of the original product.
6) If you're trying to install the Cisco VPN client, check the registry to see if any of the following keys exist:
These may be corrupted Cisco keys from previous install attempts, delete the keys, reboot, then try the install again.
7) If you see an error code of 0x800f0203 or 2148467203 (and possibly if you don't), load Windows Explorer and find the Windows\inf directory.  Look at Tools->Folder Options->View.  Make sure the 'Show Hidden Files and folders' button is enabled.  Then look at the directory for files called oemXX.inf where XX is a number between 0 and 99.  If the file(s) have sizes of zero, delete them.  Often these hidden, zero-length oemXX.inf files block installation of additional inf files in this directory.

Hopefully, this is the problem.    If this doesn't work, please  move on to (8) below (which may be very bad news)...

8) Microsoft has a bug where a Windows system gets into a state where it won't install/uninstall
any Intermediate Miniport (IM) driver (like DNE).  Microsoft ships an IM
called the Microsoft QoS Packet Scheduler.  On XP Home, I believe it comes
automatically installed.

Please go to the Device Manager (right click My
Computer ->Properties->hardware->Device Manager), Select View and SHOW
HIDDEN DEVICES.  If you expand Network Adapters, you should see

WAN Miniport (IP) - Packet Scheduler Miniport

Go to the Network Control Panel, get properties on the adapter you're using,
then uninstall the QoS Packet Scheduler.  Verify that it's gone in the
Device Manager.

Reinstall it and make sure it reappears in the Device Manager.

If this works you don't have the MS bug.  If it doesn't the only known  solution is to reinstall the OS.

If you get this far and the QoS Packet Scheduler installs, but DNE doesn't, please send me more information about your system: Other networking software installed and a list of network adapters (along with the DNE install logs).

RE: Error when installing Cisco VPN Client on Vista

Thank you for sharing that E-mail.  It is great to see when Support people actually respond in such a helpful manner.

Did any of the suggestions help you to fix your problem?

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close