×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Browser cannot resolve domain names
2

Browser cannot resolve domain names

Browser cannot resolve domain names

(OP)
Hello,

Since several days I have an issue where one of our small network PC's cannot resolve domain name addresses, while it can access external servers given by its IP address. If I try to browse for example: http://www.google.com, Internet explorer returns a "This page cannot be displayed" and Firefox a "Server not found"
The configuration of this PC does not differ from the others (obtain IP and DNS automatically) PC's of the network.
The network is just 6 XP pc's connected to a DSL router through a switch. Internal IP addresses are given through DHCP by the router.
While external IP addresses can be ping normally from this PC, external named servers cannot. The other PC's can normally surf the internet.

ipconfig /all returns the same as other PC's:

CODE

Windows IP Configuration



        Host Name . . . . . . . . . . . . : Inspiron9300

        Primary Dns Suffix  . . . . . . . :

        Node Type . . . . . . . . . . . . : Unknown

        IP Routing Enabled. . . . . . . . : No

        WINS Proxy Enabled. . . . . . . . : No

        DNS Suffix Search List. . . . . . : local.net



Ethernet adapter Local Area Connection:



        Connection-specific DNS Suffix  . : local.net

        Description . . . . . . . . . . . : Broadcom 440x 10/100 Integrated Controller

        Physical Address. . . . . . . . . : 00-14-22-EA-69-FB

        Dhcp Enabled. . . . . . . . . . . : Yes

        Autoconfiguration Enabled . . . . : Yes

        IP Address. . . . . . . . . . . . : 192.168.1.5

        Subnet Mask . . . . . . . . . . . : 255.255.255.0

        Default Gateway . . . . . . . . . : 192.168.1.1

        DHCP Server . . . . . . . . . . . : 192.168.1.1

        DNS Servers . . . . . . . . . . . : 192.168.1.1

        Lease Obtained. . . . . . . . . . : lundi, 17. septembre 2007 08:01:03

        Lease Expires . . . . . . . . . . : lundi, 17. septembre 2007 10:01:03

That would seem a DNS problem but the strange thing is that nslookup seems to work normally:

CODE

C:\>nslookup
Default Server: SpeedTouch.local.net
Address: 192.168.1.1

> www.google.com
Server: SpeedTouch.local.net
Address: 192.168.1.1

Non-authoritative answer:
Name: www.l.google.com
Addresses: 209.85.129.99, 209.85.129.147, 209.85.129.104
Aliases: www.google.com

I have read some posts suggesting to re-install TCP/IP, and others telling that the problem could come from the firewall. I have uninstalled the firewall and I have reinstalled TCP/IP (by removing the winsocket registry entries and installing it again from /windows/inf). None of this attempts have solved the problem for instance.

Any hints would be welcome.

Thank you very much.

RE: Browser cannot resolve domain names

Is File and Print Sharing disabled for the LAN connection? Obviously something is different. Can you telnet to another machine on your network, verifying layers 1 through 7? Can you ping the loopback, verifying the entire IP stack in Windows? Does the thing ping dns names if you statically assign the dns server to that of the ISP rather than that of the dsl router? Sometimes those things can have goofy NAT translation overload issues...the first thing you could do is power-cycle the router, to clear any overloaded tables, etc., and reboot the WinBlows box. Then get Linux!

Burt

RE: Browser cannot resolve domain names

I found that disabling Deterministic Network Enhancer and/or Client for Microsoft Networks will make the machine unable to resolve dns names.

Burt

RE: Browser cannot resolve domain names

Oh---what kind of dsl router, anyway???

Burt

RE: Browser cannot resolve domain names

(OP)
Thanks you very much for your comments Burt.

File and Print Sharing is enabled.
I have tried to statically assign the DNS servers to that of the ISP, but this doesn't change the behaviour.
I have tried unsuccessfully to reboot the router (an Alcatel speedtouch) too. I have also tested the PC at home with a different router (Zyxel P623-ME) and this did not solve the problem neither.
I have tried a Knoppix CD and Konqueror can browse the net with no problem!

How can I verify layers 1 through 7?
What is the Deterministic Network Enhancer? how can it be enabled/disabled?

The strange thing is that I did had not changed anything about the config. of the PC. The odd behaviour occurred after a Firefox upgrade -> 2.0.0.6. But it is not a specific problem of Firefox as I cannot ping a server by it's name.

Thanks again for your help.



RE: Browser cannot resolve domain names

What about with Internet Explorer?
Deterministic Network Enhancer is a property in Windows XP for the NIC---it is found in the same place as TCP/IP properties and File and Printer Sharing.
Telnetting a device on your LAN will resolve for all 7 layers.
Since this started happening after the last Firefox update, I would have to say it is a browser issue. Try rebooting or using System Restore to uninstall the last Firefox update. Please let me know if Internet Explorer does the same thing.

Burt

RE: Browser cannot resolve domain names

(OP)
Thanks Burt,

Explorer (It is an old version, I only use it for system updates) does the same thing. As I cannot ping a server by it's name, it seems to me than the problem is at a more basic level. I first had tried to remove Firefox, but that didn't change anything. I then had tried to restore a System and Program Folders,  backed-up several weeks before. This restored Firefox to a previous version, but did not solved the problem...
I will try telnet tomorrow.

RE: Browser cannot resolve domain names

The DNS cache on that box may be hosed. Try this from a command prompt on that pc:

CODE

ipconfig /flushdns

"We must fall back upon the old axiom that when all other contingencies fail, whatever remains, however improbable, must be the truth." - Sherlock Holmes

RE: Browser cannot resolve domain names

(OP)
Thank you for your replies.
I have tried all of your suggestions, but nothing seems to solve the problem.
Today a professional inspected the PC, and he said that there is a problem with RPC. DNS resolution works, and TCP/IP works but there is a binding missing with the system.
He recommended to fully reinstall Windows!

RE: Browser cannot resolve domain names

Are DNS Client and Remote procedure Call (RPC) services started under Control Panel-->Administrative Tools-->Services??? Iwould check other network setting services here also, like Remote Registry, RIP Listener, Routing and Remote Access, etc., though this problem seems to be specifically pointing to DNS issues. You never know with WinBlows...

Burt

RE: Browser cannot resolve domain names

(OP)
Hello Burt,

RPC as well as RPC locator starts by default automatically and they are running. Remote Registry and RIP Listener sercices too.

Routing and Remote access was set to manual and was not active. By setting this service to automatic, and rebooting, this services run normally but the DNS resolution still does not work from browsers or by pinging a named server.

Thank you for your comments.

RE: Browser cannot resolve domain names

What about the service "DNS client"? Is that running? If so, see if stopping it solves the issue. If it does fix it, then there is a local cache problem.

Another solution may be a corrupted registry entry for DNS. Take a look at:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

and "Nameserver" will have the value(s) of the DNS server(s).

As last resort before a rebuild, try winsockfix:

http://www.softpedia.com/progDownload/WinSockFix-Download-15337.html

RE: Browser cannot resolve domain names

(OP)
Thanks for your suggestion tfg13,

I finally fully reinstalled XP, and the problem got solved.

As you noted it probably was a problem of corrupted registry entries, but we could not manage to restore it. Even by uninstalling TCP services and reinstalling-it did not solved the strange behavior...



Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close