×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

perform r3 cmapi, anybody tried?

perform r3 cmapi, anybody tried?

perform r3 cmapi, anybody tried?

(OP)
i'm struggling with it in my lab, can't make it work. did all according to installation guide, created cti interface, connection manager and observer, everything green but it doesn't want to register cmapi extensions on the switch. observer log window is blank and it seems that nobody tries to access it. i know it's too broad question but where should i look first? :)

RE: perform r3 cmapi, anybody tried?

Was tutorials.sh run on the AES?  If you suspect Nice is the issue, try using the Avaya Dashboard tool to register those extensions manually and see if it works.

RE: perform r3 cmapi, anybody tried?

(OP)
tishimself,

there are no problems on avaya side, neither on switch nor aes, i'm sure of that. not only these are the same extensions used previously for 8.9 lab setup but i've used cmapi excersizer tool from perform integrations to check it, everything's okay. virtual station can be registered and can use service observing. what really disturbs me is that i don't understand wholly what the current architecture is, exactly which component is responsible for giving out commands for extension registration. in 8.9 it was cls channel manager, i guess in perform it should be rcm but i don't see anything related to extension registration in rcm logs. if i try to use cmapi tester tool i see some events in observer log as well as in connection manager log. something happens, messages are going back and forth. but when i restart the whole system there is nothing in these logs, except first three lines stating that observer is ready. it can stay in this ready state forever...
currently i have two ideas: first is that i did something wrong setting up the system (i checked and rechecked ten times, believe me) and second is that i only have logger license for passive voip and it may be the cause. in 8.9 it didn't affect anything since extensions were registered by cls but how's that in perform? if you have working cmapi setup in your lab, could you be so kind as to take a look at its license and tell me what recording type is defined there?
problem is, i can't set up perform for cmapi recording yet and i have a crowd of angry customers wanting to see perform demo and then buy it. :( *sigh*

RE: perform r3 cmapi, anybody tried?

You must start the logger after starting the Observer.  DMCC is a ****.  We have been trying to install one the last couple of weeks.

RE: perform r3 cmapi, anybody tried?

(OP)
RoamingKiwi,

so it is the logger who commands observer to register extensions? ****, it looks like i have wrong license. :( and i disagree on cmapi being ****, it works very well for the buck. in 8.9 i had no problems with it however i admit that 8.9 architecture made it nearly impossible to scale up to thousands of channels. perform should be good on this point, if only i could make it work. :( could you look into that logger's license summary.doc?

RE: perform r3 cmapi, anybody tried?

Logger license summary lists it as a standard NICELog

No licensing in the core I can see specific to DMCC.  I'm not sure how the extension registering works, I didn't end up completing the install here as was busy with other stuff so one of the other guys did it, know there were lots of problems with Avaya configuration though and then struggled with the channel mapping (thing was recording wrong extension which I think was fixed when UCID was turned on in the switch).  Sorry I can't be of more help

RE: perform r3 cmapi, anybody tried?

(OP)
RoamingKiwi,

you can't see any difference in licensing in system administrator. if you have access to configuration files diskette used for logger installation, i would like you to take a look at summary.doc there, specifically at "IP Capture type" field.

RE: perform r3 cmapi, anybody tried?

Sorry about late reply have been a bit busy lately and haven't been logging in.  Summary file as follows:

NOTE: Perform does not support VoIP older than 9.12

Ohhh, just saw what you were pointing to, you are right.

 Logger Information
----------------------
Logger Version             = VER-9.12
Product Version            = 9.12.3.20
Service Pack Version       = 3
Logger ID                  = 11668701
Customer Name              =
System Type                = VoIP
Number Of Input Channels   = 32
Number Of Output Channels  = 0
Number of ADIF Boards      = 0
ADIF Type                  = ADIF 24
PcmMode                    = A_low
FrameFormat                = CRC
Logger Windows OS          = Win2003
LAF                        = NO
Clock from PC              = YES
Synchronized Playback      = NO
Session                    = YES
N+1          = ANALOG      = YES
Pre Post Alarm             = NO
IP Capture type            = CMAPI Audio
Record Mode                = Summed
Capture Mode               = Software Only
G711 Source                = YES
G729 Source                = YES
G723 Source                = YES
G722 Source                = YES
G711 Target                = YES
G729 Target                = YES
G723 Target                = YES
G722 Target                = YES
Product Type    = CMAPI
CPU Id    = S/W ONLY
COMPRESSION    = G.729&G.723
LAST MODIFIED    = 04-01-2006 Rev A0 (C)

RE: perform r3 cmapi, anybody tried?

(OP)
RoamingKiwi,

thanks, i came to the same conclusion. more of that, i already have cmapi logger license for my lab and it does work now. so the problem indeed was in incorrect license type. sorry i didn't post update on that earlier.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close