×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Imp errors on 8.0.5.1 on HPUX 10.20?

Imp errors on 8.0.5.1 on HPUX 10.20?

Imp errors on 8.0.5.1 on HPUX 10.20?

(OP)
I have been having doing a full import into an Oracle 8.0.5.1 instance The following is the error I've been getting:

ORA-04030: out of process memory when trying to allocate 24 bytes (callheap,temporary memory)

I've tried playing around with the buffer size to no avail.

Oracle says it's an OS problem, but we've used the same account for the exact database in oracle7, and never had any problems???

Any help appreciated!

RE: Imp errors on 8.0.5.1 on HPUX 10.20?

My first reaction would be to check how much swap space you have allocated.

I've only ever got "out of memory" errors on unix boxes when there's insufficient swap (paging) space allocated.

This wouldn't be inconsistent with your experiences with Oracle7 as I'm sure Ora8 uses memory in a different way to Ora7.

There's a way to check on how much swap is marked as "in use" (I can't remember how...) but it might be interesting to monitor that whilst your imp is running - also - are there hard user or process memory limits configured in the kernel?

Regards

Mike

RE: Imp errors on 8.0.5.1 on HPUX 10.20?

I support some Digital Unix systems and I agree with Mike that V8 does require more resources than V7 did so I would check that out first.

But also, in VMS, not HPUX, so kind of a long shot but...

If you are importing some procedures...
We have gotten a similar error trying to execute some SQL statements in V8 that worked fine in V7. Turns out that the optimizer was lost in some king of loop when it was parsing the statement and just kept allocating more and more memory until it ran out. The work around was to put a RULE hint into the statement. That worked OK for us because the performance on the query was still OK. This might occur since the procedures are compiled after they are loaded.

RE: Imp errors on 8.0.5.1 on HPUX 10.20?

I would tend to agree with Mike on the lack of swap space. I know that in Linux you can use the 'top' command to see the stats on how much swap space is being used....but I don't know if Top comes with HPUX by default, though you can certainly find it on a GNU ftp site.

Good luck,

--Bryan

RE: Imp errors on 8.0.5.1 on HPUX 10.20?

(OP)
We figured out the problem, and Oracle Support is working on a bug fix.

The problem was that We were importing the schema, then the data, then the indices as 3 different imports. The failure occured on the data step.

It turns out that there was a view (a non-SYSTEM view) that became invalid and caused Oracle to go into a loop, and ending with the noted error.

The work-a-round is to recompile all invalid views before importing the data. This resolved the problem.

There was a similiar bug found in SUN, Bug # 575214. This bug should be resolved in 8.0.6.

Thanks for everyones help!

RE: Imp errors on 8.0.5.1 on HPUX 10.20?

Thanks for posting your solution. It's a bit frustrating when you're searching for a problem (because you've got it yourself now) and the problems listed on a help forum -- but not the answer.

Regards

Mike

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close