×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

ODBC 'Cannot Open File' error

ODBC 'Cannot Open File' error

ODBC 'Cannot Open File' error

(OP)
Hello,

I am attempting to connect a .dbc file through ODBC using a Visual Foxpro Driver. The .dbc file is located on another machine to which I have created a network path X:\ alias for a UNC path to that remote computer.
The ODBC accepts this during the setup, however, it throws an error when connecting to the ODBC by way of Coldfusion.
I have also only tried using the UNC path in the ODBC setup using \\192.168.0.10 , but received the same error.

Is there some type of setup that I am not understanding.

Thank you for your assistance.

RE: ODBC 'Cannot Open File' error

Turn on ODBC trace and see what is in the trace log.  That might provide a clue.

Also, can you connect to this datasource through MS Access or Excel (or some other MS tool)?

Tom Morrison
www.liant.com

RE: ODBC 'Cannot Open File' error

(OP)
Thank you for the recommendation with the ODBC trace.
I'll check it out and give you an update.

The ODBC must use Visual Foxpro Driver, as Coldfusion can only connect to the VFP DB Container through ODBC.

RE: ODBC 'Cannot Open File' error

It also is really helpful to know if a Microsoft application (such as Excel) can connect to the datasource.  If it can, then we know the problem has something to do with Coldfusion.

Tom Morrison
www.liant.com

RE: ODBC 'Cannot Open File' error

Just ran into this and dump founded also.  But went back to old DOS basics to figure this out.  I found out the files and sub files had been set to Read Only.  Took out the check box for that and everything was fine.  It would not hurt to take a look at the file setting and see what it says.

David

RE: ODBC 'Cannot Open File' error

(OP)
The culprit is security rights between the two computers.

I'm attempting to change the security settings to allow full access, but I still cannot seem to even add a file from the W2K3 OS to a folder residing in the XP OS. I'm getting 'Access is denied.'

I thought this would be simple enough by allowing full access, but it's still not letting me have full access for some reason.

I have a created a VPN which automatically connects from the 2K3 OS to the XP OS.  The network drive letter is X, and X connects through the VPN.

The user I am using is 'webserver', which resides on the XP OS, and it has full access as an administrator.  Does this seem correct to you guys?  I do not have the best knowledge when it comes to user rights.

Thanks,
Ryan

RE: ODBC 'Cannot Open File' error

(OP)
Any thoughts?

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close