×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Newby Question: MST adding extra registry entries

Newby Question: MST adding extra registry entries

Newby Question: MST adding extra registry entries

(OP)
Im a newby to WISE.. not packaging.. just WISE.

A guy at our work packaged a heap of apps and has left and once again I have to fix what doesnt work (thrown into the deep end as we always are).

One of our applications is TRIM Context and luckily an Admin install was done and an MST exists.

My problem is that I need to add extra registry entries into the MST.

I start WISE and add the entries.. compile/save the new changes and try msiexec to install the app (using the transform).

When trying to install it I get 'internal error 2715 registry 3838383'

The method I used to add the registry was to import it from a file.

Someone then told me that WISE is a bit funny and requires the application to be installed and registry to exist on the machine where I am using WISE to redo the MST. So I installed the app, imported the registry onto my machine and then in WISE drag-n-dropped the registry to my MST. I recompiled/saved the MST and tried it. It worked. BUT.. one of the registry entries that is in the MST doesnt get distributed to the workstation... Im not sure why.

So.. my questions.

Do I need to have the application that I am packaging installed onto my PC before I can compile/save the MST?

Is there a way I can Import a registry file into an MST without getting errors?

Why wouldnt the registry entry exist on the workstation the package is installed on (if it exists in the MST)?

Also, when I go and 'Check Table' entries I get a heap of errors.. is this normal?

I'd appreciate any help. Like I said.. Im a newby to WISE and need all the help I can get at the moment.

Jason
Replies continue below

Recommended for you

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close