Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here


citrix printing problem

citrix printing problem

citrix printing problem

We have nothing but printing problems in our remote location.

I will try to get to the point as this is my 2nd post, 1st one got deleted before I even got a chance to post it.

Background: Our HQ has a 5 miles point-2-point to our remote location through AT&T’s backbone using a dual T1 lease line which adds to 3mbps. In HQ we have a Citrix 4.0 with rollup3 updates running on a Windows Server 2003 SP1, our clients are using version 9 and 10. In HQ we have another server running Oracle and application database (IQMS). Remote users need to connect through a Citrix session to work off of the application database and print labels which sits on the WAN side (remote location) with a local direct TCP/IP connection directly to the Label printer, then it gets auto map to the Citrix session.

The problem is when they start to print 200 they only get 54 or so. We monitored the print spooler on the Citrix session and we see it goes all the way to 200 but again it stops are 54 labels. We looked at the size of all 200 labels and it’s only 3.48mb, so this isn’t a size issue. When printing this exactly in HQ we can even goes as high as 2000 labels without a hiccup.

We contacted a Citrix technician and they said our Label printer (Datamax) doesn’t have any approved drivers. We then called Datamax and asked for approved Windows Server 2003 drivers and they said they never had or will have any because of the $2000.00 fee for each attempted driver approval. Datamax said this might be a Microsoft issue as their drivers work for everyone else. Microsoft said when doing a test print directing it prints fine and says it’s an IQMS (application database) problem. We then contacted IQMS and they said this is a Citrix issue as their application does work on our LAN but not on the remote end. IQMS uses Label Matrix 7 to do the Label prints and also said they maybe the cause. We worked with Label Matrix and they said if we can perform a correct sample print then it’s not them, which the sample print came back good. So this goes around in circles and circles and circles. We also checked our dual bonded T1 lines for speed. We do have 2.8mbps up and down so this isn’t the problem either

Also in our own testing, we tried creating a Print server on the LAN side (HQ location), WAN side (remote location), Local (using Citrix server as the print server), and also configured the physical label printer on the LAN side while using the Citrix session on the remote side and still got the same result. My best guess is Citrix is the issue.

Nobody seems to be able to resolve our label printing problem. We don’t know where else to turn as we spent countless hours speaking to varies or vendor support and got no where. I hope by posting this on this forum and other forums somebody can point me to the solution or even a tip to resolve this problem.

Is there anything else for us to try as we depleted our resources already? Wireless connection to our remote location is out of the question because of the power lines nearby. VPN might be way too slow. Any other remote connection option going over the WAN?
We don’t want to eliminate Citrix but almost seems like we need to in order to correct this problem. Do we need to look into a 3rd party application such as thin print, or using a thin client, or even terminal services? Anyone have any experiences in those fields.

Thanks in advance.

RE: citrix printing problem

Just as a matter of interest have you tried running the application fat client over the WAN. If the printing does the same then its no Citrix, it might be slow, but the printing function shouldn't matter.

Alternatively have the queue for the printer in HQ pointing to the WAN TCP/IP. At least worth a try to see what happens.

A perspective from the other side!!


RE: citrix printing problem

Fat client over the WAN?

So you mean to run the application database locally on the remote side over the 3mbps Point-2-Point connection?

if so yes we tried that which it ends up being really slow and printing is no problem, so its really is the Citrix.

yes we having the que pointing to the WAN tcp/ip

Citrix session is much faster but the printing issue is drive us crazy.

RE: citrix printing problem

I thought the app would be slow, but it proves the printing issue is citrix sided.

Have you imported the HQ print queue into the Farm ? Then give it to the remote users ?

What should happen is the Citrix session should be making a direct connection to the HQ queue and then print straight over the Link to the printer, something seems to be getting in the way of this.

So to re-cap, the way it should work...

a) create queue for printer on a Server (Not Citrix Server)
b) Impoprt the queue into the farm
c) In Printer management select the printer and select which users to give it to or which workstations.
d) Make sure the client is not selecting their client connection to this printer. Ie a Citrix client printer. Cos this will be as slow as a slow thing with ....you get the picture.
e Test it.

A perspective from the other side!!


RE: citrix printing problem

Alos not that if this is being attempted by the locally attached (to the client) print queue, you are fortunate to be getting anything at all.

Print should be generated at the Citrix server and passed directly to the queue on non-citrix server. Then passed to the device.

A perspective from the other side!!


RE: citrix printing problem

Thanks for your time in helping us out with this issue.

How do I import the HQ print que to the Citrix?

RE: citrix printing problem

Printer Management in the Management Console. Right click printers and import I think, its been a while. Once they are imported then you can set policies for them

A perspective from the other side!!


RE: citrix printing problem

Thanks i have now added the printer to a non-citrix print server

how to set policies to the printer?

when I right click the printer it just shows me "add client"

If i do choose add client, then it ask me what driver name, what printer name, device, and such.

this doesn't seem right. or is this the correct procedure?

I would imagine what should come up is a window box to add the users I want and that's it.

any suggestions?

RE: citrix printing problem

ok policies, i got it. I applied it to the entire remote subnet. they are able to see my printer I have setup as a import.

still it stopped at 56. i tried for 130. The citrix session spooler goes all the way to 130.

This is so weird.

RE: citrix printing problem

Can you run the app from the Citrix console ? Say try 130 from there.

It is possibly a driver issue with the printer, make sure it is the same as the "other box" driver ?

A perspective from the other side!!


RE: citrix printing problem

I do have an alternate idea, we use zebra printers in our enviornment, but you have to watch what drivers you use or your citrix servers will just start blue screening a different points during the day because of the drivers are NT V2.0 drivers which on citrix is BAD.  There are some drivers that you can use that aren't bad, just test them first on a test citrix server.

RE: citrix printing problem


Before I install the database application, can you tell me how this procedure will benefit the issue?

All boxes have the exact same driver, directly from Datamax.

I also don't think it's a driver issue.

I can print over 54-56 labels on the LAN with the same driver
I can print over 54-56 labels on the remote LAN without using Citrix with the same driver

Only when printing in Citrix I can't print over 54-56 labels.

This has been tested and documented so I can say with confirmation.

Question is, Citrix connection is preventing from printing over 54-56, is it the way data is transfered? does that make a difference? I would imagine it doesn't matter why type of data as everything goes through a packet.

RE: citrix printing problem

No the application is running on the server, in its own little environment. Remember all that goes up and down to client is keyboard mouse and video. The issue is btween citrix server and print queue.  Not the client.

By running the app at the console you are taking citrix out of the equation. You are simply using the server as a laptop. The app should already be installed on server so why install again ?

Just log in at the console and run the app see what prints, by running from console you are by passing any citrix stuff. Purely use the server console as a desktop.

A perspective from the other side!!


RE: citrix printing problem

It's Tuesday right after the Holiday here.
Ok I'll try it at the Citrix server itself.

But if the HQ client can print fine with no problems, we already know we can rule out the Citrix server, right?

Like you said its the problem from Citrix to the print que going over the WAN, not LAN right?

RE: citrix printing problem

Well yes and no.

We know than client - Wan - Citrix - app - Print q - Wan - print-device is not working.

We know that client - app - print-q - wan - print device does.

I want to know if citrix box - app - print q - wan - print-device does or not.

Its a case of tryiing to decide at which point it is broken.

A perspective from the other side!!


RE: citrix printing problem

Hi, sorry my reply has been delayed. I didn't quite have access to the Citrix box for the test. But finally I had the oppurtunity for the test.

I have done this test in three categories of where the Print Que sits.

WAN = printer is located on the remote end with a TCP/IP connection directly to the printer, LAN = printer is located on a print server in Head Quarter, and Local = printer is located on the Citrix server.

Print result: Failed in all three categories.

With the WAN connection it just errors out.

With the LAN connection, the pages would go up in parallel together all the way to 130 and nothing gets printed at the end.

With the Local connection, the right side of the page goes all the way to 130 pages while the left side would build to 130, and at the end nothing gets printed.

Also I have done a test print straight from Windows test print and all three came out fine through the Remote Desktop Connection.

What are we eliminating from this test?

RE: citrix printing problem

Kracksmith, let me give you my experiences.

I have a I-4208.  Redirected printing to it via RDP (not a Citrix environment) was pretty similar to what you are seeing.  The printer was shared via a parallel connection to a desktop.  We might get a few good print jobs from our desktops (just a few labels each), and then the printer on the terminal server would get stuck.  The PC sharing it could print to the printer locally fine, as could other PCs on the network, it was just the redirected jobs.  After awhile, the whole terminal server would lock up.  And mind you, this is all over a local area connection.

When I put the network interface card into the Datamax, and I created a printer on the 2003 terminal server and pointed it to the IP address of my new network card, using Seagull drivers (sounds like you are using Labelmatrix drivers), it works like a champ.

The connection between your remote and main offices, do you have a VPN?  You might consider creating a tunnel if you have the equipment, so the terminal server can directly communicate with and print directly to the printer.  

There is something funky about redirected printing in general with the Datamax printers, via RDP or ICA.

It sounds like right now, based on your first post, the Datamax printer exists on the terminal server, because your desktops at the remote site have a TCP/IP connection to it, and the terminal server is trying to redirect the print jobs that way.  Try it via RDP instead of Citrix, bet you have the same problem.

Your ideal configuration is to have the users run the application via Citrix, and the terminal server they use should have a direct TCP/IP connection to the printer, which will occur  over a VPN.  


Please always take the time to backup important data and verify that backup, before making any changes suggested.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close