×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

TM_6281 error on Sorted Aggregator

TM_6281 error on Sorted Aggregator

TM_6281 error on Sorted Aggregator

(OP)
Good morning-

I have created a session in which I have added an aggregator.  When I select the "Sorted Input" property, I get the following error:

Quote:

TM_6281: Partitioning option license required to run sessions with user-defined partition points.

When I de-select the "Sorted Input" property, it runs fine but it spends needless time caching my entire table to file.  Does anyone know why this might be happening and/or a possible resolution?

Thanks in advance,

--Rob

RE: TM_6281 error on Sorted Aggregator

(OP)
I apologize; I forgot to mention that I am using Informatica 7.1.3.

Thanks!

--Rob

RE: TM_6281 error on Sorted Aggregator

(OP)
I again apologize; I forgot to check the knowledge base.  In case anyone else encounters this:

Quote:

To run a PowerCenter session with a sorted Aggregator transformation set the server parameter AggSupprtWithNoPartLic to "Yes" as follows:

Unix
Using a text editor open the PowerCenter server configuration (pmserver.cfg) file.

Add the following entry to the end of the file:

AggSupprtWithNoPartLic = Yes

Re-start the PowerCenter server (pmserver).

Windows
To set this parameter on Windows refer to article 11486

(article 11486)
To add a PowerCenter Server parameter (that is not in the server configuration dialog) on Windows enter it in the registry as follows:

Click Start, click Run, type regedit, click OK.
Go to the following registry key:
HKEY_LOCAL_MACHINE\ SYSTEM\CurrentControlSet\Services\PowerMart\Parameters\Configuration

On the Edit menu, point to New, and then click String Value.
Enter the String Value "SERVER_PARAMETER".
Go to Edit > Modify.
Enter "VALUE" and then click OK
Re-start the PowerCenter server (Informatica Service).
Where SERVER_PARAMETER is the name of the parameter and VALUE is the setting of the parameter.

Sorry!

--Rob

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close