×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

ERROR MESSAGE RUNNING CLARION V2.1

ERROR MESSAGE RUNNING CLARION V2.1

ERROR MESSAGE RUNNING CLARION V2.1

(OP)
I'm trying to run reports using Clarion v2.1.
The progam and data are located on a Novell 3.20 server, the workstation is using windows 98.
The problem:  every time a report is activated when others are sharing the data, I crash out with the dos error :5.
The other workstations (W95) do not have this problem - and all settings appear to be similar.  Any ideas out there?

Colin

RE: ERROR MESSAGE RUNNING CLARION V2.1

I suspect it may be related to file Shares.

I used to program Clarion 2.0 for DOS and found it necessary to add SHARE.EXE to the autoexec.bat file
ie. SHARE.EXE /L:20 /F:8192

I'm not sure of the syntax but it was similar to above.
Windows needs a file handle for each key file, and the
default file size (/F:4096) was too small for a large dataset with many files and keys.

You may have to hunt around to find a copy of SHARE.exe as I don't think it is shipped with Windows98.

RE: ERROR MESSAGE RUNNING CLARION V2.1

We have Version 3 of this ODBC driver and it doesn't work real well. I was wondering if you might know where I might find a version 2 TopSpeed ODBC driver. SoftVelocity doesn't seem to be able to help.

RE: ERROR MESSAGE RUNNING CLARION V2.1

I am confused by your last post.  There no ODBC driver for Clarion 2.1x DAT files so you statement is misleading.  As to the issue you identify in your first post it sounds like a network stack issue.  Compare the stacks installed on the correctly working w95 stations.  The problem you identify sounds like an incompatibility between the client OS and the files server OS, not a Clarion one.

HTH

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close