×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Dell Servers in HPSIM5.1

Dell Servers in HPSIM5.1

RE: Dell Servers in HPSIM5.1

Hi,
I'm by no way an expert on SIM, and don't claim to be!
However, I've been through the same document you've linked above, and managed to get (eventually) an amount of data pulled back from the Dell's.

I have the problem of supporting servers over ADSL WAN links, with no Domain Trusts - and I admit, I'm still struggling... however, the local Dell and HP Servers monitored by SIM chat quite happily to each other!

You have to add the MIB's in, as per the document you've mentioned above.

Then make sure SNMP is talking correctly - much easier on a LAN, or Company WAN than straight over the net.

1) SNMP must be running, and configured with a Community string that is reflected the same on ALL servers and the machine with SIM - SIM also have to have the same Community String: Options | Protocol Settings | Global Protocol Settings

Also you MAY have to have a read/write Community String - I'm a tad confused here - I think older versions needed read/write - but I've read mixed reports about whether 5 does or not (you certainly need Read though) - if you're servers are not directly on the net, and you have a good Firewall blocking outbound SNMP, then you'll be fine. If not, test it with both - and as always, finish with the most secure way that works!
Also, set SNMP to receive from 'Any Host' to start with - basically, get it going, then start to tighten the securty screw...!

2) After then running an Options | Identify Systems this may or may not pull limited information through.

3) as I found out only yesterday, after about 6 weeks of battling on... install the 'WMI Mapper fo HP SIM' (is part of the SIM installation - but I deselected it - oops!) - you can get this seperately from HP.com.

Run the ID Systems again, and you should start getting somewhere...
You (with any luck if you're running on a LAN) should get more info than I can. I keep getting 'No WBEM Support detected' errors - and I'm working like mad to get WBEM working - not sure it will over a WAN with no Domain Trusts though...

Like I said, I've done quite a bit with SIM recently, and I'm starting to get somewhere! So, if you're still having problems, post back on here, and I'll see what else I can think of.

Also, I hope none of this is teaching you to suck eggs - and apologies if it has...!

Good luck!
Thanks, Mark

RE: Dell Servers in HPSIM5.1

(OP)
Mark,

Thanks for your long reply. I have read through it with great interest. I have followed all your instructions with great care and several times to ensure that I did everything correctly. In short I still had no luck with getting Insight to recognise Dell models and OS versions it is running.
I am begining to suspect some sort of MIB curruption somewhere and thinking of rebuilding the whole server.

The original instructions which I have followed to install and configure Insight were from the document below. Not sure if there are any recent versions, but even if there was, I would think that it would be 99% same.

I am still playing with this and any progress I would surely place it here for others to see it.

http://www.dell.com/downloads/global/solutions/Integrating_PowerEdge_Servers_into_HPSIM50.pdf

RE: Dell Servers in HPSIM5.1

L4ts,

I have got fed up with the seriously SLOW performace that having SIM running on my Desktop is causing (I was testing it, to make sure it does pretty much what I want...).
So, I have plonked it onto a server - and I can't be assed with any migration options - I've settled for a fresh install and re-discover.
This means (to your advantage), that I have to register the Dell MIB's again, and get my SIM5.1 discovering and collecting all the data again...
So I shall take notes, and make sure I post back here - hopefully with some helpful advice!

Watch this space!

Thanks, Mark

RE: Dell Servers in HPSIM5.1

L4ts,

I am having half the problems you are!
My Dells and HP on the LAN are seen fine - pulls back Dell model numbers and OS version.
However the ones I'm talking to over the WAN do not. They simple display 'Dell' with no OS or model number.

The ones I'm connecting over the WAN are only using:
SNMP 1.0 (when clicking on the machines properties then Product Description), despite having other protocols enabled...

The LAN machines are using:
WBEM1.0 and SNMP1.0.
My SIM Server (which I have had to put on a Dell!) is using:
HTTP; WBEM1.0; SMH2.0 (VC only with it being a Dell server); SNMP1.0 and SSH

So, I am starting to guess that WBEM maybe the key here.

Out on interest, what is your network config like? Are you trying to use SIM to monitor machines on the same subnet, different subnet or different networks altogether? Also, do you have any firewalls getting in the way?

Once I installed SIM, I then followed the 'Integrating Dell PowerEdge into SIM 5.0' document - carefully following pages 13 to 19, and noting (what I think an a typo on page 14) - step 2 says:
'enter command mxmib -a newdcstorag.mib' - where as step 1 above it, says 'mxmib -a new10892.cfg' - so I replaced the 'mib' with 'cfg' on step 2...

I'm afraid I've not got any other ideas!
One thing to note, is that the logging of what SIM is doing seems to be quite good.
Select a Dell, then Options | Identify Systems | Run Now, and watch for any errors - it displays 'Checking for WBEM' - or words to that effect - my machines on the WAN respond with 'No WBEM Support Detected'.
After that, it processes SNMP - I'm now getting a response from SNMP, and this allows limited information to be pulled back to SIM.
If you're getting neither on a LAN, you have something wrong! Community String, or a problem with WBEM.
I don't understand WBEM yet, I'm still working on that - so I can't shed any pointers! However, like I said before, I think it was the WMI Mapper that helped here...

Good luck with it!
Mark

RE: Dell Servers in HPSIM5.1

(OP)
Mark,

I am currently trying to get this working on our internal network. Once it is all up and running I will punch some hole in the firewall for our DMZ subnet but for now the priority is to get this to run on the internal network.
Since yesterday, I have found an old compaq desktop and installed insight manager on to it.
Well, after following the instructions to setup Dell servers, I was suprised to see that it actually worked!!
I had no chance to look at what differences there are, but I now believe the answer lies between the two (Dell PowerEdge 1950 vs Compaq Evo D5S).
Tomorrow, I will go through this desktop step by step and compare it to the Dell server to understand it better.
Overall I think we are making progress and should have something very soon. Thanks for your help!

RE: Dell Servers in HPSIM5.1

Hi L4ts,

One thing I forget to mention!!
I've read many posts on the HP Forums that suggest deleting the servers you've discovered (or the problem Servers), and re-run a full discovery. This - apparently - can resolve many problems - and would possibly fit with the issue that your new Desktop with SIM works, but your Server that you've been changing settings on for the past few days, does not...!

But yes, sounds like you're making some progress - good news... hope it continues and you get all the data collected that you need!

Thanks, Mark

RE: Dell Servers in HPSIM5.1

(OP)
Mark,

Finally.....After changing the WMI credentials in Global Protocol Settings (Options/Protocol Settings) to include domain before the username (domain/Administrator) I have started getting some results where SIM was able to see which OS version the server is running.
I am currently running a scan using an IP range and will let you know of further developments.

Thanks.

RE: Dell Servers in HPSIM5.1

L4ts,

Thats great news!
That is the problem I'm having - as I have no Trusts, and can't create any (due to policies, etc...!), I have no way of entering Domain authentication details - I have tried like you, and putting 'domain\username' then password - however, with the fact that the authentication is initiated from my domain, but the WMI credentials being for another domain, it simply fails to bring any details back - other than 'Dell' in the Server field - no OS, no Model number, etc...

I am wondering (but not tried it yet), about trying a standard username and password across the board - then the only change will be the Domain name - but judging by the fact that you had problems until entering a domain, I doubt that will work either...!

Anyway... hope it continues to work successfully for you!
Cheers, Mark

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close