×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Postgresql won't startup anymore

Postgresql won't startup anymore

Postgresql won't startup anymore

(OP)
I've done something to my postgresql server (on Fedora Core 4 Linux)and I can't get it to startup now.  I'm a novice to this application, so please go easy on me as I'm trying to learn it.  I was running version 8.0, but went ahead and tried to upgrade to 8.2, thinking that a new installation would maybe overwrite whatever settings I screwed up and get me operational again.  What I mean by "tried" is that I downloaded the binaries and ran them, and they acted like they installed, but when I do a 'psql -V' it still says 8.0.3.  When I try to run the command 'psql' I get the error message:

psql: could not connect to server: No such file or directory
Is the server running locally and accepting
connections on Unix domain socket "/tmp/.s.PGSQL.5432"?

My postgresql directory is under /usr/local/pgsql.  Is this an OK location to have it?  The /usr/local/pgsql/data directory contains the pg_hba.conf and postgresql.conf files, among others.  These files look unchanged from their default settings that came in the binaries.  The /usr/local/pgsql and all subdirectories have the user postgres as their owner.  When I su as user postgres and go to the directory /etc/rc5.d/ and run './S64postgresql status' it says 'postmaster is stopped'.  When I run './S64postgresql start' it was saying:

cat: /var/lib/pgsql/data/PG_VERSION: Permission denied

An old version of the database format was found.
You need to upgrede the data format using PostgreSQL.
See /usr/share/doc/postgresql-8.0.3/README.rpm-dist for more information.

Any ideas or tips to try?

GVN

RE: Postgresql won't startup anymore

when you say you downloaded the binaries and ran them - what exactly did you do.  which files did you download - from where - and where did you put them?

RE: Postgresql won't startup anymore

(OP)
I finally got it working.   It turns out that the /var/lib/pgsql directory and all subdirectories didn't have the user postgres as the owner of them as well...

Thanks anyways,

GVN

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close