Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here


Faxual II error

Faxual II error

Faxual II error

We have been using Faxual II for many years now (version 1.07 950808). The computer running the fax server is using DOS and appears to run OK. The modem is a USRobotics 14,400 fax modem. The program uses the sample sending routine with no changes apart from screen messages.

My problem is that any fax sent to some specific numbers ALWAYS fail with a "Page Not Acknowledged" error after the first page. We can manually send from our real fax machine OK to all of these numbers. We have asked and the receiving faxes are just normal fax machines. Most numbers work as expected.

Any ideas as to what may be causing this and how to correct the problem?

RE: Faxual II error

Hi, Hoteye

Although I have no experience with Faxual II software, I have used USR fax modems a lot. You don't specify the model (Sportster, HST?? External??) but one thing for sure - that modem design is over 10 yrs old. It isn't really surprising it may have problems handshaking with some newer machines which are unable to stupid themselves down to Class 1.

A lot of things have changed since then, and now a fax machine typically receives directly into memory and will ack each page very quickly, whereas your modem/software may be allowing a settling time which is overly long and therefore missing the end of page acknowledgement.

If this has suddenly started happening I would first of all try another phone line, preferably one not going thru an exchange or centrex - maybe your existing line is noisy and causing interference at low signal levels. Then I would try swapping the modem, though it may be difficult to find a 14.4 now, the current V92 faxmodems will likely still work.

Faxual II is used to fax out of Clipper programs. Do you have access to the source code? Do you know the fax init string?

Faxual II supports Class1, 2 and 2.0 modems, so it should be possible to get it working on newer equipment. Looking around, it would appear your version is quite outdated - there are patches available to take it to 1.09 and  there also seems to be a version 2.01 out there.


RE: Faxual II error

Back on 10 Nov 03 12:56 you answered at thread with:
"I am using a Clipper application on a Novell Netware 6 server and all works fine. I have DOS, Windows 98, Windows ME, Windows 2000 and Windows XP clients.

I do not know if Netware 6.5 has changed, but I would doubt it."
My question is, have you had success running your Clipper applications on Netware 6.0? I starting a simular port from Netware 3.2 with many Dos Client clipper 5.2e applications. It was mentioned in another thread that you have to use bindery emulation with Clipper is this true?  I am getting an error "Error recovery failure, ORDLISTADD (0)" Some Clipper applications work that don't use the ORDLISTADD function from a Utils.LIB that is used.

RE: Faxual II error

We have been using a Clipper program on Novell 6.0 for some time now (years!), and it works very well.

I do use Bindery mode and connect with IPX/SPX. I use the SIxCDX driver for indexes. There is an OrdListAdd in the SIx driver, but I do not use it.

But I do use dbSetIndex()...
if !NETERR()
    * Create the TAG RYO index
    index on Recno() to (zTemp4) empty

I changed dbSetIndex to OrdListAdd and it still works OK.

Are you sure the index file is ok?

Kind regards

RE: Faxual II error

Hi Jock,
I've been testing here.

I do have the source code and am able to compile it. The init string is ATM1 (audible while connecting), and is soft coded in a setup database. I think v2.01 was Faxual, not Faxual II.

I've upgraded to the latest version of Faxual II. (At least I went through all the instructions, but it reports 1.08 even though I installed 1.09!) No change.

I then tried the Sportster modem on an outside line and it works ok.

I then found a newer USRobotice 56K Message Modem (c1999)and tried that, but the same as the Sportster... fails going through switchboard but OK on direct line.

I have spoken with our phone support firm and they say it must be something to do with sending over a digital line (ISDN30), but cannot fix it.

I have emailed Faxual II and they have said the same thing... use an analogue line.

Unless you can suggest some init codes to try I will have to install another analogue line sad but at least it will work.

Thanks and kind regards

RE: Faxual II error

Hi, Hoteye

Suspicions confirmed.

I have spent lots of useless time trying to get analog modems working thru digital switches and almost always to no avail. Even if they can get it to work it is unreliable when connecting to some machines, which is pretty much your experience.

I'm afraid a POTS line is the best way forward. Having done that, you may find the 56K will give higher xmit speeds on some connections.


RE: Faxual II error

Hi Jock,
Thanks for your help. I'll have to get a phone line installed.

Kind regards

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close