×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Unable to run PSP 11

Unable to run PSP 11

Unable to run PSP 11

(OP)

Hi everyone,

I've had PSP 11 for about 2 months now, but lately everytime I tried to open the program, I get this message:

"Runtime Error
 Program...PaintShop Pro X1/Corel Paintshop Pro.exe
 R6025  - Pure Virtual Function Call"

Then the program would shut down.

I've tried uninstalling and reinstalling the program. It worked for about a day, then the problem came back.

Does anyone knows the solution to this problem?

TIA

RE: Unable to run PSP 11

Did you install the update patch?

RE: Unable to run PSP 11

(OP)


Yes, I have installed the update. After this problem started, I was promted that update was available. It seemed to have installed ok. Although I have not reinstalled the update after I reinstalled the whole program. I will try that now.

Thanks for your response jconingham.

RE: Unable to run PSP 11

(OP)

I've just reinstalled the update. Unfortunately it did not cure the problem.

Any other ideas?

RE: Unable to run PSP 11

I'm not very familiar with XI but if Corel didn't change things too much there should be an option somewhere in the File menu for you to reset the program's preferences. This is known to fix a few occasional problems.

Corel also offers a program, zapps.exe, that is supposed to help you fix registry problems. You can download it from ftp://ftp.corel.com/pub/PaintShopPro/X/ and the instructions for using it for this case are at http://support.corel.com/scripts/rightnow.cfg/php.exe/enduser/std_adp.php?p_sid=JxNfuBri&p_lva=&p_faqid=760103&p_created=1158609088&p_sp=cF9zcmNoPTEmcF9ncmlkc29ydD0mcF9yb3dfY250PTQwJnBfc2VhcmNoX3RleHQ9dW5pbnN0YWxsJnBfc2VhcmNoX3R5cGU9MyZwX3Byb2RfbHZsMT0xNTUmcF9wcm9kX2x2bDI9fmFueX4mcF9zb3J0X2J5PWRmbHQmcF9wYWdlPTE*&p_li=

RE: Unable to run PSP 11

(OP)

Hi jconingham,

I've tried uninstalling and reinstalling PSPRO 11 using zapps.exe and there was something I've discovered.It was the update/patch that was messing up my program. I've tried it a few times doing clean install but everytime I install the update, I get that same runtime error. There is another thing also- everytime I reinstall PSPRO 11, Snapfire+ reinstall automatically. I wonder if other people experienced that same thing. Looking at the programs on my cd, seemed like Snapfire+ is an option that should not install by itself. Right now my program is stable but without the update/patch. I will try to email this problem to Corel tech support, but I welcome any input from anyone.

TIA

RE: Unable to run PSP 11

(OP)
Info for anyone who might run into this problem in the future:

There was a similar problem in Corel's tech support Q&A, and the solution suggested was updating the nVidia graphics card. I have an ATI Radeon in my system and I found out it needed updating. I found out too that my BIOS could used some updating also, so I did it after the graphics card. Those two updates seemed to have fixed the problem. Not really sure though if the BIOS had any helped at this. Maybe it was just the graphics card that solved it all.

RE: Unable to run PSP 11

Thank you for posting the solution to this problem Rivo.

Learn something new every day
Using Crystal 8, Oracle Database Paint Shop Pro X1 Nikon D80

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close